How do i close open spaces

Untitled.skp (1.6 MB)
how do i close the 2 open spaces on the side of this design

Imported STL? The geometry is pretty messy.

First thing I’d do is run CleanUp3 which would get rid of quite a lot of the unneeded geometry…

There’s more to clean up. The edges bounding that opening on the side have some problems that will require a bit of work to fix before you can get a face there. There are other places that are problematic like those edges that run diagonally to the holes. The underside has some similar issues.

If this was a project I was handed to do, I think I would use this as a rough guide and redo the model entirely to make sure it’s all correct.

I’m guessing this is for 3D printing. Is that correct? The original units were metric. Instead of using Architectural (feet and inches), you should work in decimal metric units. I would scale this up and work in meters as if they were millimeters. For example, the box is 92mm long. Model that as 92 meters. When you export the STL for printing, it’ll be unitless so it won’t matter that you modeled in meters. You’ll import the STL into the slicer with millimeters as the selected units.

By the way, what version of SketchUp are you using? Your profile says you are using SketchUp Pro (Subscription) and it also says you are using “pro free” but that doesn’t exist.

oh … sorry i just started today
2019 or 18 whichever one is the most recent
yes i am doing this for 3d printing
and why is it that hard to close a model

it seems like their would be a setting that would fill any holes

In this case you’ve not made the edges coplanar. The edge shown selected in blue is not running in the same direction as the other edges. Faces in SketchUp are planar so to get a face all edges have to lie on the same plane.

There is. It’s completing a loop or edges that lie in the same plane will automatically close the face. Sketchup has no way of knowing whether or not your edge is out of plane intentionally or accidentally.

Here I have the basics of the box redrawn. That face filled in easily on my version because I made sure to keep the edges coplanar.

that worked
thanks for your time

1 Like