Can't see template

installation

#1

I’m just trying to get started. The program is running, tools work, but the working area is whited out.
I’m using an up to date version of Win7 SP1 Home Prem. 64 bit ver 6.1.7601 running as a guest on a Kubuntu 14.04 using VirtualBox.
My original install worked but dropdown menu submenus were not visible. They worked, just truncated. The template was visible and tools worked as expected.
I enabled Virtualbox’s 3D support and turned on Windows Aero. This fixed the menu visibility, but now the template was white. It’s there, just underneath. if you make a blind change, it gives the save dialog on exit.
I tried un and re- installing SketchUp with Aero on, but no luck. I looked thru the menus, but am not familiar with Sketchup. I didn’t find anything.


#2

Very likely the problem is related to your graphics card. Radeon cards are well-known to be lacking in adequate OpenGL support. You might try disabling Hardware Acceleration in SketchUp’s Preferences (Window menu) and see what you get.


#3

Thanks for the quick response.

Once Open GL is unchecked the program crashes. When I try to restart I
get a “Sketchup was unable to initialize OpenGL, error: choose pixel
format failed”.

I’ve had other problems with this Radeon (on board). Which ones seem to
work?


#4

Did you do something in the GPU’s driver settings or did you turn off Hardware Acceleration in SketchUp’s OpenGL Preferences?

Most users seem to have the best luck with nVidia graphics cards.


#5

Made the setting in Sketchup.

VirtualBox has has 2 different interfacess, the default is WDDM for Aero
support, and Direct3D (noted as experimental). I am using the WDDM.

Given other problems with Radeon (Kubuntu 16 doesn’ like it either) I
think I will opt for the nVidia.


#6

Also consider that SketchUp is not supported for the way you are running it in Virtual Box so your mileage may vary.


#7

Thanks for the help.

As far as VirtualBox SketchUp compatibility, prior to enabling Aero it
appeared that Sketchup was working fine. Just a problem with the drop
down menus. I’ll get the card and it either will or it won’t


#8

I stumbled upon what was causing my problem in SketchUp. In the process
of trouble shooting some general display and stability bugs running Win7
in VirtualBox, I found that 3D acceleration had been enabled all along.
Unchecking it (settings> display> 3D) solved my other problems and
SketchUp now works.

SketchUp 2016 doesn’t like 3D. Hope this will help others.

Andy