Can't save model

recently upgraded to 2021, been modeling fine but today the ‘save’ is greyed out and when I try save as it won’t allow me to. It says to check if I have ‘write permissions’? (not right?) At a loss as to what to do and have hours of work that needs to be saved. Thanks!

When you installed SketchUp 2021 did you right click on the downloaded installer and choose Run as administrator? If not, close SketchUp and do that. If prompted, choose Repair.

In Window>Preferences>Files, what is the save to location for Models?

it looks like save to location is documents.

I think I chose administrator, but I’m checking that right now. I have 4 models up right now- how can I save so I won’t lose them?

Can you upload them to the 3D Warehouse? Or maybe Publish them to your Trimble Connect storage?

I’ve never done either, but I can try. a couple are large files- is one easier/better to do than another?

whats weird is I upgraded back in end of nov maybe but it was allowing me to save then

Assuming you have a subscription to Trimble Connect, you should have unlimited storage while the 3D Warehouse has a file size limit so it’s possible that you could upload to TC and not 3DWH. I don’t think either is difficult to do. If you go the Warehouse route, you might want to make sure you set the files to be private unless you’re OK with the world having them.

It may be that repairing the installation will fix it. There must have been some change on your computer since you installed SU in November that is impacting this.

hmmm- I use trimble warehouse, but don’t think I have a subscription

Are the other ‘Save’ s also greyed out? (Save as, Save as Template, Save a Copy)

no, but when I tried save as it said I don’t have write permissions-

oh you’re talking about the subscription rather than the classic license? I was waiting until my coverage finished to switch over

That implies a problem with permissions for the location you’re trying to save to. Do you get the Save windows with the location indicated?

I just tried to ‘save as a copy’ for one of them to the desktop and that worked. but I still think I need to figure out why this is doing this. I’m not sure what you mean ‘Save windows with the location indicated’?

Try to save the other files as well, are you having multiple instances running? You might have opened one double. Close the app when you ‘Saved as’

do you mean close sketchup after saving?

this is what I’m getting everytime. But it’s still not letting me close the files because I’m not saving them correctly I guess?


If the ‘Save as worked, close the app without saving that one and fix the permissions, first.

I just saved them as copies then clicked
out of the other ones without saving them.

ok, I’ll try that.

so I looked and it has me as the administrator- how do I fix permissions?

I opened one and it seems to be fixed! I think it maybe was a matter of closing them all and restarting? I don’t know. But thank you both for helping me troubleshoot this!