Can't open projects or save anything


I use sketchup free quite often with no issues, but today I cannot access my projects or save anything! It let’s me sign in and I can start a new project, but when I try to save or open my existing files, I get a sad looking Panda bear saying “something went wrong trying to load this folder” and a retry button, which does nothing.

I have refreshed browser and restarted computer. All OS are up date.

Thougths? Ideas? Helps?

What browser are you using?

Currently there appears to be an outage with Trimble Connect. See


Same issue, Chrome on Windows

See the link I posted.

I am having the same issue. My home tab no longer has my recent sketches and if I go to the Trimble Connect tab I get the sad looking Panda. I am using Chrome, and I cleared all browsing data and tried again, still having the issue.

Thanks so much for this! Makes me feel better that it’s not just me. I’ll keep an eye on that page and try again later.

Ok I see the status link. I went to the site to check maybe 30 mins ago, I thought I had saw everything was running. Maybe I missed it.

Maybe your timing was such that you looked at the page just before it got updated.


I’m also glad that it’s not just me.

Same issue here - Chrome 114 on Windows 10. Tried clearing cache twice, still no joy.

Did you read my post, above?

According to the Status site things are back up and operational.

Yes, thank you. Should have prefaced just validating what posters and OP are seeing. Hope it is back up sooner than later.

The Status site now indicates that Trimble Connect is operational.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.