Can't open file Error "This does not seem to be a sketchup file!" please help

Villa 30 furniture (54.4 KB)

You can see that the zip file is 1000 times smaller than the SKP was. That’s because the file is filled with zeros. There is nothing in the file that can be recovered.

Hello Colin, yes i find that weird also, but i couldnt upload the actual file because it is 54mb so i had to compress it. when i open the file on my computer, it gives the error

That’s the point Colin was making. Zeros in the file compress to nothing. The SketchUp file is already basically a zip file so compressing it into a zip file wouldn’t change the file size significantly if the file was correct in the first place.

oww ok i understand. thank you for clarifying. i guess there is no way of recovering my work… :frowning:

Did you look for the .skb backup file? Can you open that?

Where have you been saving the file to?

Yes i tried opening the backup file also but it says the same error.

Try zipping it like you did with the .skp file. Does it end up as a tiny file like the other one did? If so, I’d say your best bet is to get started rebuilding the model.

Again, where have you been saving the file to?

Yea i tried zipping it and it was 50kb which is nothing. guess ill remodel it. thank you so much for the help. ive been saving it on my local ssd.

As you are working along through the modeling process save to your local drive and also publish the model to your Trimble Connect storage so you have an extra backup. Trimble Connect will also automatically create a history so if you have some reason to go back to an earlier version of the model you can do that.

ow wow thats actually very useful, never used the Trimble connect storage before. i will start using it. thank you so much again.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.