Can't make object solid for 3d print


#1

Hello. I hope someone help me. I’ve been struggling to make an object ready for 3D printing. I just started learning sketchup so I may be doing something wrong. I deleted all the internal geometry but it still says object is not solid when I use the outer shell tool.

Can anyone take a look and see what is wrong?

AArmstrong_syaoran_goggles_01.skp (497.0 KB)


#2

I had a look at the model and you have a few issues: see pic. I tried ThomThom’s Solid Inspector tool but it can’t fix it. You could try to fix it manually but maybe it might be more quick to start all over again…?


#3

give ThomThoms ‘CleanUp³’ tool a try too.


#4

Using ThomThmos solid inspector was reporting many short edges, reverse faces and short edges plus there are a number of stray lines and holes.
After scaling up by twice by 10x and fixing holes the best I’m left with is 2616 internal face edges and 1 surface border. Those you will have to fix.
To use the solid tools you need to make model a component. Attached is may last change , it is still at 10x, 10x
good luck.
I changed to 2016 since could not find one tool I wanted, you can save back to 2017
AArmstrong_syaoran_goggles_01.skp (679.8 KB)


#5

Thank you! I will try to work with this file.

I am trying to use the solid inspector but it says it has an out of date signature.


#6

One option that works well for me most of the time is to upload my file to Microsoft’s Azure server, https://tools3d.azurewebsites.net. This free service fixes STL files so they are closed and ready to print.


#7

Try uninstalling the extension and then reinstalling using the latest installer version from the Extension Warehouse.

Cheers
CD