Can't load Plugins in Sketchup Make 2016

Ruby Plugin instruction call for *.rb files to be installed in a plugins folder:

Windows - the default location is:
•SketchUp 2016: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins

I am installing on a MS Surface Pro 4
I do not have app/data/roaming/ path

My Sketchup files are located in
C:\Program Files\SketchUp\SketchUp 2016\Tools.
installing the *rb fils in tools folder is not working

What is the correct procedure?

That is not the correct location to install plugins. Do not add plugins to the Tools folder if you want them to work.

There is an App Data/Roaming path but it is normally hidden so you would need to unhide it first to gain direct access. Normally you shouldn’t need direct access to it since most plugins/extensions now come with the .rbz file extension. They can either be installed directly via the Extension Warehouse or the Sketchucation Plugin Store. Other plugins that you might download as .rbz can be installed via Preferences>Extensions>Install Extension.

What plugin are you trying to install?

Change the Windows folder options by opening any Window browser window and going to Organize (Win 7 shown) to open the folder options dialog

.

1 Like

If you type “%appdata%” (without the quotes) into the Search box in the Windows Start menu or Start screen and press Enter, Explorer will take you to the Appdata folder.

The correct path is
C:\Users\<your username>\AppData\Roaming

Anssi

1 Like

Quotes don’t seem to matter. It will bring you there anyway.

All:

Thanks for the helpful responses and Windows 10 tutoring ( I have been too many years with a corporate computer and was unfamiliar with unhiding hidden files. I have a lot to learn about self-IT support.)

I attempted to load plugins form the link in the video “Usefull Google Sketchup Plugins” - https://www.youtube.com/watch?v=5Fdo3telGaU. The link from the video notes is not through the Sketchup Extension Wharehouse. … Lesson Learned

I think this should close this thread

You can mark the topic a solved by clicking the little check box under the response that solved your problem.

That looks like a good video! One issue for you may have been that it is almost five years old. Extension management has changed in the last half decade!