Default Location for the Plugin Folder in Sketchup 2014

When I try to install a new plug in into Sketchup 2014 and I use the - Windows - Preferences -
Extension - Install Extensions ---- I’m only allowed to use the *.rbz files. How do I install, and where
do I install the *.rb files. I’m using Windows 7.

If you have a plugin that is not an RBZ, you can place it in the correct folder on your computer (see the link below). If your plugin is listed on the Extension Warehouse, I would just download from there (and EW will tell you if the plugin is compatible with your version of SketchUp).

Check out this post by ThomThom - he does a good job of explaining about the new plugin folder.

Let me know if this helps or if you still need assistance!

In v8M2/v2013/v2014 you should be able to install any RBZ archive using the > Preferences > Extensions > Install… button.
When you say ‘you are not allowed’, what do you mean?
Who or what prevents you ?
What error messages do you get etc ?
What errors?
Do you have SketchUp setup to ‘always run as admin’ under Properties > Compatibility ?
Are you an admin ?
Where do you save the RBZ file ?
Have you tried a direct auto-install of a tool from the Extension-Warehouse [or SketchUcation’s PluginStore] ??
More info please…

When I use the “install extension” drop down box, it will only recognize the rbz extension
If the extension is rb it is not found. Any rb extensions that I have placed directly in the
c:\user… \plugin folder have not been recognized. I’ll get it eventually, but it is very
frustrating. I sure thank you for the reply

The native Installer only installs RBZ archives.
The alternative SketchUcation installer installs RBZ and ZIP archives.

If you have a lone RB file you could ZIP it… and use either auto-installer.

But in the case of the native installer you will need an additional step - i.e. add a new .rbz file-type suffix to the ZIP file [an RBZ archive is simply a renamed ZIP file!]
However, if you have SketchUcation toolset with the plugins-folder addition you could simply open your Plugins folder from within SketchUp…

Or use this snippet in the Ruby Console +:


Then you could manually add the RB file into that folder…

BUT this begs the question… what lone RB file do you want to add to your Plugins collection?
All EWH tools come as RBZ archives.
And 99% of non-EWH Plugins at SketchUcation are also available as RBZ from their PluginStore…
Most other scripts which you might get from elsewhere are also unlike to be guaranteed to be compatible with v2014…
Simply copying RB files from an earlier version’s Plugins folder is a recipe for problems.
There might well be support files in related subfolders or incompatibility issues with v2014.
Always install the latest versions - most important Plugins have already been updated to be suitable for use in v2014…

1 Like

You are going to a lot of trouble trying to help me and I’m thankful.
I’m trying to install “House Builder” I’m obviously new at this, but this plug inis terrific and it’s apparently not ‘updated’. Thanks again. I’m using Windows 7

The plugin folder for SketchUp 2014 (windows) is located in

“C:\Users(Your username here)\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins”

The AppData folder is by default a hidden folder, so, you might have to tweak your Folder Options in Windows Explorer to see it.


1 Like

‘House Builder’ comes in at least two flavors - the improved metric one and the original imperial version in inches [there’s also French metric - but I expect you are ‘English’].
The metric one from the Depot is known to have incompatibility issues when installed with v2014.
This has been discussed at length on

There is much advice there and a fixed metric version…
This particular LINK is to a post on this incompatibility issue - there’s a fixed ZIP metric set to download - rename the .zip as .rbz, auto-install and all is well

The Depot’s imperial version ought to be compatible with v2014 - but its .zip does need renaming .rbz to to allow you the simplest auto-installation…

You have gone all around the houses with your Plugins folder question - which actually stems from a plugins incompatibility with v2014…
If you ask the right question you get the right answers…

I hope this now addresses your issues… :smile: -)