Can't install any extensions. At all

Keep getting the same error message:

Something went wrong during the authentication process.

Please contact system administrator.
Reference ID: 70a22c21-50cb-4896-adb1-e6ed6ead419c

Try signing out and then sign back in using the sign-in button at the lower left corner of the main window.

Which version of SketchUp 2015?

Which “main window”?

The only places I have ever seen to log in are all at the top right of
any window.

And how would I tell what “version” I have? It’s Sketchup2015. That’s
the version. It’s not 2014 or 2016. What difference does it make?

Also make sure that you have installed SketchUp properly.
The [only] correct way is to close SketchUp, then find its installer’s exe file [probably in your Downloads folder], right-click > context-menu > "Run as administrator…"
When prompted, choose to “Repair”…

This will ensure SketchUp is properly installed.

Of course all of the earlier ideas might also help fix things…

Okay, I’m lost now.

Are we even talking about the same thing? I’m trying to find out why I
can’t install any extensions. You’re talking about the window where I
do work. The two don’t have anything to do with each other, the way I
remember trying to install extensions. All sorts of new windows opened
up for me to search through them, etc.

It says “Make”. Although again, I don’t know what that has to do with
the price of tea in China. If an extension won’t install, it’s the
extension, not the program.

I don’t use IE. I use Firefox. Which is totally irrelevant. Firefox
has nothing to do with Sketchup.

I don’t think you’re answering what I’m asking. I don’t know what to
do with anything you’ve said, because none of it addresses the inquiry
I made in a way I can understand.

In SketchUp you have to log in here:

To gain access to the warehouse here:

EDIT, However there may be more to it, as TIG mentions below. But logging in is a must to access the extension warehouse properly.

We might be answering at least some of your questions, if you look without preconceptions…

The inability to install extensions can be a result of SketchUp not having been installed properly.
Hence my suggestion for you to try and reinstall it correctly.

After SketchUp has been properly installed, then perhaps your ‘extension-installation’ issues with be solved ?

You may well use Firefox as your default Internet browser [I do t!oo], however, on a PC SketchUp will use IE for its various web-dialogs [with v2017 this has changed, but most extensions that are backwardly compatible will still rely on IE !] - for MAC users - that is IE >>> Safari…
Purging the IE cache can sometimes fix weird issues with SketchUp…

‘Make’ or ‘Pro’ are not different in the way they need to be installed.

So sorry that I don’t already know everything you know.

And I don’t even have IE to be able to do any of the things you
suggested doing to it. Even if I knew how to do those things.

Wish you could remember what it was like not to know everything.

Sigh…

All you guys know far too much to be able to help someone who doesn’t
know what you know.

If Sketchup is not installed correctly, it did it itself. I followed
the provided instructions to the letter. FYI, it was uninstalled twice
with Revo, and reinstalled exactly in accordance with the provided
instructions.

Can’t do a thing to IE, if it isn’t on my computer. The guy who built
it for me made sure it wasn’t installed. Therefore, I don’t have it.
Since I don’t have it, I can’t do whatever I’m being told to do to it,
because it isn’t here to be able to do it. Even if I knew how.

Forgive me for being too stupid to be able to follow all these
instructions that I don’t understand. If the lot of you are all having
the same problem, then perhaps you might consider that not everyone
knows what you know, and respond accordingly.

I never had this problem with Sketchup 8, or with 2014. Since I never
had the problem before the installation of 2017, logic tells me that
it must be 2017, and not me.

It really must be nice to know so much that you can’t remember what it
was like to not know anything. I apologize for not knowing enough to
know how to ask a simple question.

Hello @Lancer525 and welcome to the Community Forum.

Your obvious frustration is understood. I think all of the previous advice was offered in sincere attempts to help. Each of us was new to this software at one time and this forum’s participants have a pretty decent record of assisting and answering questions correctly and to the point (with a particular emphasis on helping new folks).

As mentioned before, the inability to install extensions is often associated with a problem in installing the program on your system, which is why some of the comments referred to that.

I ask that you exercise some patience and try to implement the suggestions you find here. Remember the respondents cannot see your screen so much of what is suggested may be guesses based on their own experiences. Keep asking questions and where you are able, post an illustrative image or the actual skp file.

Believe me, most times these folks get it absolutely right.

1 Like

Since all versions of SketchUp need to use IE for some of their dialogs I can’t see how you ever got the earlier versions to work IF as you say you don’t have IE installed at all.
Where your earlier versions on the same computer, or have you had it 'rebuilt; recently ?
Since it’s a basic part of a Windows installation I don’t see why the guy who set you up ‘removed’ it.
It could cause all sorts of unexpected issues.
Perhaps he simply set you default web-browser to Firefox, remove IE shortcuts etc, and IE is languishing somewhere…

Since you have only just now told us the possibility that IE is not available, that could be a clue as to what’s up…
Look in C:\Program Files\Internet Explorer
IE is iexplore.exe
If it’s there try running it,
Also using the Run command with iexplore + enter should open it.
Then you can access the cache etc…

Also your Control Panel > Internet Options should still be available ?
That lets you manage the cache too…

Assuming that the IE issue is a red-herring…
It is vital that SketchUp is installed correctly.
I never said to uninstall it - and certainly not using a 3rd party app like Revo…
I’ll restate the correct method, for the avoidance of doubt…
Find the SketchUp installer’s exe file - e.g. in your Downloads folder.
Select its icon - do NOT double-click it, because that will run it incorrectly.
Right-click > Context-menu > "Run as administrator"
In the installation dialog choose “Repair” if it’s offered - i.e. SketchUp is already installed.
Otherwise choose to install it - i.e. you have uninstalled it [somehow]…

Your profile also offers no info on your Graphics Card.
SketchUp v2017 requires support for OpenGL 3 or newer…
It’s important that you have up to date GC drivers installed.
To find your GC open Control Panel > Device Manager
Find Display adaptor and that gives you the GC name…
Select it and right-click and choose Update Driver Software…
Choose to let your computer search the www to see if there’s an update available…
If so install it…

The least problematical GCs are usually Nvidia, some others like old Intel and Radeon are know to be flaky…

Let’s cross the GC driver updating etc bridge when we have traversed the installation swamps a little more !

1 Like

EDIT: This is off-topic, if it can be moved please do…

It’s not that simple. When folks say SketchUup uses Internet Explorer, it does not mean iexplorer.exe which is just a front-end. “Internet Explorer” is also a bunch of functions in libraries used for rendering HTML, networking, and for a multitude of other things. You can create your own browser front end and use the “Internet Explorer” rending engine as the back-end.

It may be possible to remove iexplorer.exe the web browser from Windows, but it is not likely possible to remove all the internet explorer libraries and still have a working Windows.

Of course SketchUp 2017 uses CEF, which itself uses Blink.

2 Likes

The same is true of Safari on Mac. The underlying library is WebKit.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.