Can't edit materials

I have been using Sketchup for several years. Just now, I clicked on a material to edit its color and a window popped up saying, “Materials must be applied to the model before they can be edited.”

I of course applied the material to the model but got the same error alert.

Never seen this before. Any ideas?

Thanks.

What version of SketchUp are you using? What operating system? What graphics card. Complete your forum profile.

You need to select the material in the In Model materials before you can edit it. You cannot edit a material in its collection even if you have applied it in the model. You must be in the In Model collection.

In previous versions of SketchUp you could appear to edit the material in the collections on Mac, but any changes you made would be forgotten next time you opened the file. And so with 2024 a message is shown saying that you have to edit the material in the Colors in Model set.

“a message is shown saying that you have to edit the material in the Colors in Model set.”

But this is not what the message says. It says you have to “apply the material to the model before editing it”. As with the OP, I find that even if you apply the material to the model, it still gives the same alert message.

After applying the material so you have an In Model material, switch to Colors in Model and with the material selected, edit it.

1 Like

That is one difference in the way Windows does it. If you select a material in one of the sets, and dare to go to the Edit tab, all of the options are grayed out. If you apply that material to a face, now the Edit options work. Which could leave you thinking that you are editing the material in its original set. You’re not though, on Windows the In Model copy of the material has been selected for you, and that’s what the Edit tab will control.

The wording could be changed to make it clearer that you need to switch to Colors in Model to be able to edit the applied material. I will pass that on to the UI team.

To everyone who replied, thank you for your help. Dave R. solved it.

As it turns out I misunderstood the command (or alert, whatever). When it says “apply the material to the model”, it means you need to edit the material in the “In model” window. I was clicking on the material that was literally “in the model” and was trying to edit the original material thumbnail.

Thanks again!

LT