Can't download SketchUp Make 2016

download

#1

I have SketchUp Make 2015 but when I tried to open a file it says it was saved in a newer version and I have to download the latest SketchUp version, but when I have done that it says the same.

It seams like donwloading the latest version only gives you the 2015 version again.


#2

Where are you downloading it from and are you installing it after downloading? Installing SU2016 does not replace SU2015. They would both be on your computer unless you uninstall SU2015


#3

From Sketchup.com.
Yes, I run it too.
I think I deleted SketchUp Make 2015 before downloading SketchUp Make 2016. I don’t remember exactly.
(I don’t have to have SketchUp Make 2015 in my computer already to be able to download SketchUp Make 2016 do I?)
I only get SketchUp Make 2015 from downloading SketchUp Make 2016.


#4

No. You don’t have to have SU2015 to get SU2016. What operating system are you using? Your profile is missing all kinds of useful information like that.

Are you sure you installed SU2016? Can you find it in the list of programs and open it on its own? How did you delete SU2015?

Try downloading it from here and install it. http://www.sketchup.com/download/all


#5

Now it worked! Maybe I didn’t uninstall the old version properly, I’m not sure. Thanks!


#6

Glad you got it. In the future do not uninstall a previous version until you have the new one installed and working. And when you do uninstall, use the proper procedure to make sure it is uninstalled correctly.