Can't download from Warehouse. getting Terms of Use popup and the 'By Clicking Here, I accent The Above Terms' will not WORK!

3dwarehouse
tos
termsofuse

#1

I am a Sketchup Make 2017 user. I could previously download from the 3D warehouse with no problem.

I tried to download from the 3D warehouse today within the Sketchup app and I get the TERMS of USE pop-up and there is a button at the bottom that indicates to Click it to accept the Terms. I click it and nothing happens. It is even hard to see if the button is grayed out or not.

I am obviously signed in as I am in Sketchup doing my modeling and trying to access the warehouse within the app.
I also tried going outside the app to the 3D warehouse and signing in separately. Still same problem.

What is happening?


#2

Scroll to the bottom then accept.

Its SketchUp’s attempt to get you to read the agreement.


#3

I just noticed this as well and think it is definitely not obvious that there is more text. Browsers nowadays hide overlay scrollbars, and it is not visible that this text is clipped inside a box.

A visual hint should be added (border, fade-off, arrow icon…).


#4

This topic was automatically closed after 91 days. New replies are no longer allowed.