Can't Change Size of Dynamic Components

I’m having trouble changing the size of some components from 3D Warehouse (in particular, Marvin Windows and Doors components). I’ve tried scaling with the scale tool, but there are no scale handles on the object. So I edited the dynamic component options for height and width, which I assume is the correct way to scale this component. Whenever i do this, the component just goes haywire and the frame stays put while the interior parts of the window move outside the frame (below it), but nothing changes in size.

Any ideas? Thanks!

Kindly,
Hal

We will need a component id or two from the 3DW in order to give an opinion. Or complete URLs ?

Of course, sorry for not including. Here is a link to one that does this:

I can add a screenshot of what’s happening, but I don’t immediately see how to post a photo.

I just played with: “Marvin Clad Ultimate Double Hung Cottage Style Window”

Yes, it is weird, BUT,… the Height and Width fields are informational.

You select the Model # from the bottom-most drop-down list control, and the HxW is changed for you.

Aha, okay. So to be clear, if I don’t see a model number that has the dimensions i’m looking for, i should look for a different component?

The formula are set up to calc off of the choice of model number. So it’s either that or explode the component, and resize things manually.

Awesome. Thank you. I hadn’t thought of exploding it.

Actually I just tried the one you linked to. The first control is a choice of “Standard” or “Custom”.
Choose “Custom” and then change the width. Click the Apply button at the bottom of the dialog, and it will recalculate.

Yeah when I do that, it messes up. How can I post a photo of what it’s doing?

Okay figured out how to post an image. Here’s what happens when i change the size from 36" to 24". It does make the window thinner. but the whole interior of the window moves down below the frame, and that little bit of frame stays put, effectively doubling the height of the component and obviously rendering it unusable.

Can you export the view via File > Export > 2D Graphic…

Then attach the image to a post by either drag-n-drop, or use the upload icon (7th from left on the post edit toolbar,) and browse to and select the image file.

1 Like

It works OK for CUDH-NG3234 E. Perhaps that one model’s formulae is buggered?

EDIT, no it works OK, for me CUDH-NG3230 E, as well.

What are your model units set to ?
Perhaps try restarting SketchUp ?

BTW, I drew a wall, and inserted the windows, and let them “glue” to the vertical wall face.

You have not which likely is confusing the formulae as to what is x, y and z axis.

Yeah it still doesn’t work for me with that model either. I guess this component is just screwy. Anyway exploding it worked fine. I just had to modify the glass after and re-make it into a component. Thank you!

No, see my edit of previous post.

I have tried actually rebooting my whole computer, and starting from a blank file as well. It doesn’t work when glued either.

Here are the unit settings:

Well here is the simple wall model (v15) with the 24" window:

Marvin Windows.skp (1.3 MB)

Well this is crazy. If I open your model, I can modify the component just fine. If I start a new file from scratch and download the model from 3DW then it doesn’t work.

is it possible that you have some data stored in your default template that is clashing with the DC?

Try choosing s different default template, then try opening a new download of the component.

And the obvious difference here is hmayes is on Mac using Safari (Webkit) for the DC dialogs, and I am on Win7 using the MSIE WebBrowser Control.

Good idea, but same result with a different template.