Can't change my Trimble Password

I am using Sketchup 2018 and can’t upgrade as 2018 is the last version which supports my 3DConnexion SpacePilot 3DMouse…

I needed to get an extension today and realised that I no longer have the “Google” login opition as the version of Sketchup is not supported… So I must use my Trimble password.

I thought I knew what it was… But after a few attempts I realsied I was going to lock my account… So I decided to use the “Forgot Password” feature… But nothing has happened… I havn’t had an email with a link to change the password (and I have even checked my SPAM).

I have tried all of the features available (ie Create Trimble Password, Reset and Forgot Password) and none generate a mail… So I am locked out…

Does anyone know how I can get my password changed? Does Trimble have a support desk who might help?

Its OK… Problem solved… I logged in with 2020 and my Google login still works, but not the Trimble password.

But unlike 2018, the ‘Forgot Password’ feature works as it takes you to a URL:

https://identity.trimble.com/trimble-identity/identity/main/forgotpassword?sp=sketchup_login_prod&lang=en&application=sketchup_login_prod

I was able to change my password now and I am in… So ignore this, but I have left the post incase it helps someone else .

Cheers

Jon

2 Likes

Thanks for posting the direct link Jon! That’s a great tip for anyone who’s having problems accessing the reset password form inside older versions of sketchUp.

You can also reset your password from any of our properties in your web browser. Just opt to sign in, enter your email and then click the forgot password link.

Lastly, if you ever get locked out you can follow the same forgot password process to clear that lock. You can set your password to what it was (or what you thought it was :wink: ) previously.

Bryce