Can't bring up right click menu to create new components


#1

using sketchup web on a Mac using firefox. Right click after selecting geometry only brings up four options (view image, save image as, select all, and inspect element). No options for make component ,etc. I can make a new component by pressing “G”…but its annoying i can’t see the darn right click options. Any advice? I tried safari…but safari won’t run cause it won’t save any of my files (gives an error).


#2

Are you right clicking on the selected geometry?


#3

Sounds like you are getting a browser context menu rather than SketchUp’s context menu. A screenshot would help to know for sure.

If that is the case, using another browser could solve the issue.


#4

yes i am right clicking on the selected geometry. I can select the simple cube (for example) geometry…and then press G and it will go right ahead and pull up the make component menu for the item i selected. when i right click…just the browser context menu. strangely enough…sometimes i get the browser context menu over the sketchup menu. will try restart. Also tried using safari and it won’t save. I just get the “sorry we are having trouble looking up your models. Our team has been notified.” message.


#5

Is there an update available for Firefox that you can install?


#6

i am facing the same issue now… any solution?

(i use Chrome)


#7

I’m using Chrome and right clicking on the selection brings up the context menu for me. Is your copy of Chrome up to date?


#8

Hi, I have the same problem and just checked Chrome - it’s up to date. Any suggestions? I’m using Windows.


#9

What happens when you right click on selected geometry in SketchUp on Chrome?


#10

Thanks for responding so quickly! Here’s what happens

:


#11

I can’t tell from your screen shot what you have selected. It looks like maybe you have only selected an image. Try opening a new file. Draw a cube, select all of the geometry and right click on it. can you make a component then?


#12

I did select an image. I’d like to save it as a component so I can delete it and use it elsewhere. Sounds like one can’t do this with images, only objects?


#13

Explode the image so you have a face, edges and a texture. Then make that a component.

A component needs to contain some geometry.


#14

That worked beautifully, but now the image itself is flickering and shows on both sides of the wall. Is there a way to make it more stable?


#15

That’s called Z-fighting. Move the image component off the wall a bit so it’s not touching it directly.


#16

I will try this in my next session. Thank you so much for the help.
J.