Newbie Unable to right click to group?

Hi, sorry I’m new to Sketchup. I’m following the tutorial, and am at the point where I use the selection tool to triple click on an object, and I’m supposed to right click to group and object. However, I’m completely unable to get that menu when I right click. As I am on the free web version, I also don’t see any edit menu, it’s only the edit menu of my web browser… Please help anyone? Using Macbook Air with external mouse, Mac OS Mojave 10.4, even tried trackpad while holding control, still nothing…

There is no Edit menu in the web versions like there is in the Desktop versions.

As for right clicking and bringing up the Context menu, that should work. What browser are you using? What kind of mouse?

Also make sure the cursor is “on” one of the selected entities when you right click. You won’t get the context menu if you right click in empty modelspace, the selection will just deselect.

2 Likes

Chrome browser. Using a Logitech mouse with 4 buttons and a scroll wheel tried them all. but at the very least, the trackpad while holding down control should work, shouldn’t it?

I definitely did make sure the cursor was on one of the selected entities. don’t know why it’s not working.

What version of Chrome?

If you start a new file and right click on Helen does anything pop up?
Screenshot%20-%206_23_2019%20%2C%204_54_24%20PM

says my chrome is up to date, v 75.0.3770.100.
as you can see from the uploaded pic, i get a right click menu that seems not from sketchup.
as for right clicking on Helen, I still don’t get the right menu, I get the same thing. 09%20PM

You’re right. That’s not a SketchUp Context menu.

Hey guys, I solved it by using the Safari Browser. Who would have thought that safari would work better than chrome for this? I had thought of it earlier, but didn’t think it would work… Thanks for your replies and for being kind enough to help!

1 Like

Normally it should work in Chrome, too. In fact my screen shot was made in Chrome. I have a vague memory of this coming up for someone else but I can’t remember the solution and haven’t found the thread yet.

Yes this came up before but I don’t recall what happened either. I were using chrome just a short while ago on PC with no issues.

I were going to have a guess that the browser window weren’t maximised to the screen but I’m not familiar with how macs work to really know if that would make a difference anyway.

There are several things about Safari that are better than the same feature in Chrome. But as far as the SketchUp goes, I’m sure a lot more testing is done in Chrome than Safari, and they should work the same.

I found a Chrome extension that lets me right-click on elements in the SketchUp app. I’ll find a good use for that some time! But, even with that extension I would still get the SketchUp contextual menu as well.

Do you have any Chrome extensions that could have interfered with the right-click?

Ian, on Mac it shouldn’t matter what size the browser window is, and people generally don’t maximize windows.

Thanks Colin, I realise now the menu that is appearing is in fact a browser menu and not coming from some other background app that I started to think.

not sure what kind of chrome extensions would prevent the menu? but it doesn’t matter to me, I’ll use safari for now. thanks guys. another problem i encountered was at the end of the tutorial it told me to go to the top menu and select shadows and add colors, which again you can’t do on the free web version. However, I found Shadows and colors on the menu from the right side, with materials, display, entity info, etc. Now I’m trying to find out if it’s possible to add a hinge to an object… designing a bench with a flip top and shoe rack underneath…