Cannot sign in

Every time we try to sign in we get a login loop, and we’ve tried everything recommended and still get the same error. @CaseyG

Hi @jjohnson, thanks for the post and thanks for using the @ command to get my attention. I am happy to assist you in getting SketchUp for Schools up and running for your students. A log in loop is typically a sign of a bad deployment so my first suggestion would be to run through the deployment process and make sure that you are not missing any steps.

If you have already done that, my next guess would be that the sign in pop up window is being blocked by something. Some pop up blockers keep the log in from going through and can result in what you are describing. Try disabling that and see if the issue resolves itself.

If neither of those work, we can try some additional troubleshooting steps.

In case you need the deployment process outlined, I’ll link a few videos in this post.

Good morning CaseyG, in my high school we use Gsuit but our domain does not end in *.edu.
Last year we could use Sketchup for schools perfectly. Is it possible that our domain has been removed from your whitelist?
Right now we cannot access the application for schools. We went into a loop and have done everything you recommend to gain access.
Our domain is
Please, we need to be able to use Sketchup imminently.

Thank you very much and greetings.

Carlos Sanz

Hi @carlosanz, thanks for the post. I am happy to work with you to get you added to our database but the fact that you have had access in the past and lost access tells me that the most likely cause of the loop is something on your side rather than ours. I would recommend checking with your IT team to see if they changed anything that might be affecting things on your side.

If you would like me to add your domain to the database, I am happy to do so but will need you to confirm that you are a k-12 school or equivalent. I gave your site a look, but I don’t speak Spanish and can’t rely on Google translate to confirm things. Can you confirm that you are a k-12 school or equivalent?

Hi CaseyG,Thank you very much for your prompt response.
The school administrator was there today trying to understand what was wrong but he didn’t see anything out of the ordinary.
On the other hand, how can I certify that my organization is a Secondary Education center in Spain…? What document do you need?
And what else can we do to be able to use Sketchup for schools?

Thank you very much and receive a cordial greeting

Thanks for the reply @carlosanz. As I have already replied to this topic in a different thread that you posted in I will just close out this topic. In the interest of future users who may see this I’ll go ahead and list what i said in the other threads again here.

As I was able to verify your info I was able to get you added to our database but the symptoms you are describing are more consistent with a permission issue on your end. I would highly recommend checking with IT again and making sure they did not accidentally override any past settings If nothing obvious is wrong, I would also recommend trying a redeployment to see if that clears up the issue.