Cannot select certain entities

I have a Pergola made of various components (posts, beams, cross support beams, joists, etc). I’ve worked with each piece before, but all of a sudden I can select ONLY the cross support beams. When I try to click on the posts or joists, SketchUp will select something behind that entity. If I use select to draw a square around the entities, it also doesnt select them. However, I did find that if I zoom out sufficiently far and select a large area, that it does include those entities in the selection group.

The entities were previously buried in nested groups, but I’ve since exploded all groups to bring it to the top. Still, I cannot select the entities.

In the screenshots, I try to click the pink post. But instead, it selects a line on the pavers behind the post

Here I try to select a large area containing the green beams, blue joists, and yellow louvers.

After selecting, the green, blue, and yellow entities are still not selected. Yet, the diagonal cross support beams are selected. along with some entities in the background

How can I gain access to these entities again?
Note: this is a large file (22MB). I’m fearing I may have some corruption

Upload the file to DropBox or WE Transfer and share it so we can see what you’ve got going on.

Your profile says you are using the free web version. Is that correct?

Without seeing the model I can only guess that you have grouped things in some bizarre way so that the things you are trying to select are parts of larger groups that don’t fit inside your selection box.

I discovered an odd effect. after ungrouping everything, if I go into the Components menu and open a broken component. And then If I select “Always face camera”, the component disappears from my model. And deselecting this does not return it to my model. Nor does “undo”. it seems clicking that button permanently removes it from my model.

At this point, i’m just recreating the components. very odd.


Again, without seing your model, it’s only guesses.

but my guess is the same as Anssi’s.
If you zoom extent (the one with the 3 arrows) you might actually see that selecting the elements selects something. something so big that when you ask SU to have it face you, what you see is the empty space between the elements.

but then again, bure speculation. could be a bug. or a ghost. or a broken mouse. or…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.