Cannot scale in mm - keeps reverting back to same scale

Why would LO keep reverting my scale back to 1/2" = 1" when I am trying to have it in 1mm= 2mm? Everytime I click to put it into 1mm:2mm. It loads up and looks like it changes but then it just goes back to 1/2" to 1" and also the orbit tool keeps popping up when I try to do anything.

Now I can’t do any dimensions in mm and it is always making me do my dimensions in inches even though I put the scale to mm. I drew everything in mm so this is a real pain in the but.

Here is the screenshot of me putting it into the scale:

690x388](upload://I am about ready to give up with Layout.


The way Layout shows scales may be a bit confusing. Scale is a simple ratio. You have chosen half full scale (or 1:2 or 1/2 or 0.5). It makes no difference whether you are in metric or imperial and it makes no difference what units you use providing the ratio is always 1:2. So 48:96 would achieve the same as would 2019:4038.

How units show in dimensions is another matter entirely and depends on your settings.

1 Like

You’ve written this in two threads now. It tell me you are double clicking on the viewport. Don’t! If you want to change the scale of a viewport, select it with a single click. Then adjust the scale. If needed, drag the edges of the viewport so you can see the model but do not double click to open the viewport to use SketchUp’s camera tools.

Here I single click on the viewport. Set the scale in the SketchUp Model panel (get in the habit of keeping that visible in the tray when you are working with viewports.) Moved the viewport on the page and resized it by dragging the edge. Hold Alt to resize from the center while dragging an edge.

That’s a good point. I was kind of thinking that about the scale but wasn’t sure because l was getting dimensions in inches while in another drawing using 1mm:3mm scale, it was working fine and using mm dimensions. Can you please give some basic info in the settings for the dimensions in layout? I was trying to set this in the preferences but it seems to keep staying in inches? Thanks

Units in Preferences only affects the display of things like move distances and grid spacing. If you want dimensions to be displayed in metric units, you need to do that in the Dimension panel while you have the Dimension tool selected.

You would really benefit from going through the LayOut Essentials here.

Thanks again Dave. I am finding the course you recommended quite helpful.

Great animated instruction! Thank you. It is interesting that when you click 1mm:2mm it quiickly changes it to 1 iinch to 2 inch. I am wondering if this would affect issues on the printout to have it in 1 inch to 2 inch when you are work in a 1mm:2mm?

It has been mentioned before that the way Layout shows scales is a bit bonkers. I only work in metric so all my scales show in mm. But the actual basic ratio is also shown without the units in brackets. That seems like gilding the lily. But on top of all that, you might logically expect the options to be in a logical order, but they aren’t (that may be a Mac only thing - not sure).

I confess that I don’t understand why there has to be a list at all. You could conceivably have just two boxes: one where you input a whole number (50 to get 1:50, say) and an alternative where you input a decimal (0.4 for 2:5, say) for those very rare occasions when someone might need a very peculiar ratio.

Here’s what I see in my current setup:

As you can see, I seem to have ended up with two versions of half scale and some options are show no decimal places and others show a single decimal place. It’s really quite unnecessarily busy and confusing IMHO.

That’s because I selected a template that had Preference Units set to inches instead of millimeters and I already have a 1":2" scale. I’d made a 1mm:2mm scale just before making the GIF. The scale is exactly the same however. 1:2 is 1:2 no matter what the units are.