Cannot position axis in 2024

for some reason, in files that I made earlier that I am now opening in 2024, when I right-click on the axis lines in groups, I don’t get the place/ move/ reset axis options anymore. Is anyone else having this issue?
I have attached a video, first of the file in 2023, where everything is good, and then in 2024, where the option doesn’t show up.

I don’t normally use groups in my model but I just did a test with a group in a new file. It worked as expected for me.

I am having the same problem with components also. However it is only in old files, If I make a new file it is working fine.

Here’s changing axes for component from an old model.
axis comp
I frequently change component axes and so far haven’t seen any issues in SU2024.

Which graphics engine are you using?

I can change axis that way, as well as with the axis placement tool on the toolbar, however if I go into the group/component, and right click on the axis line, if it is an old file I don’t get the place, move, or reset axis options.

old file

I don’t get those options.

when you say old, do you mean a 23 file in 24? or like a v7 file ?

I’ve tried with a group made last year in SU23 and another made in SU6 in another life, they both give me the option on mac.

Could it be a PC thing ?

Could you share a file that refuses to shift axis maybe ?

By old I mean 2023.
I am attaching a file that has this problem.
In the main context this works, but if I enter a component it doesn’t work on the component axis.
campfire.skp (1.8 MB)

I don’t get the standard “place move reset” but instead, in the middle, a “modify axis”. works the same for me.

Yes, but it doesn’t have the reset option, which I use sometimes.

I wonder if it has something to do with the fact that you’ve scaled the objects in the model but never scaled the definitions.

ahh, gotcha. didn’t see the video in the first message :confused:

and yeah, if I make a group in your campfire file, I can’t move the axis using right click. the axis tool still works.
but in another SU23 file of mine, I can.

something’s wrong in your file maybe? :slight_smile:

I tried that, still the same.

It is in more than one file, it is in most of my files, here is another one.
cow1.skp (264.3 KB)



But I think it’s a bug @colin or at least it’s not great.

Ok, I made a group of the fire, copied it into my default template, and… it worked.
So I went and checked the differences between your file and my file and I found it.

Go to window / model’s info / components and untick “hide”

Capture d’écran 2024-04-17 à 22.34.31

that way, opening a group or component won’t hide the rest of the model BUT it gives you the normal right click on axis thing.

the reason I could see it in all my files is because I don’t hide the rest of model. at least by default.

Capture d’écran 2024-04-17 à 22.36.33

you can do the same through the view menu.


Thanks, that fixed it for me too, but I still think it is a bug that should get fixed. Thank you for your help (and dave for his time).


It seems wrong to me too. I haven’t yet found an existing bug report about it. I will make one.


thank you

Thanks a tonne for finding this solution, I was going bonkers to not able to do it, I hope SketchUp devs fix this in the coming days.