Cannot create a component with newest version of Pro 2021

Has something changed in creating components in the newest version of pro 21?
When clicking on ‘Create component’ the axes mark shows up, but everything else locks up. No box for writing: Definition of component or anything else shows up. Need to ‘esc’ to cancel and no component is created.
PS. Everything is working as usual in pro 2020.

The process for making a component is the same as it’s always been. What happens if after starting to make the component you just hit Enter?

I expect the Create Component window is opening off screen. When you installed SU2021 did you right click on the downloaded installer and choose Run as administrator? If not or if you don’t remember, do it now and when presented with options, choose Repair.

Please update your profile, too. It says you are using 2017 Make.

Hi Dave. Thanks for quick reply! Yes, it works pressing ‘enter’ and I can then define the component under ‘Entity info’
I’ll try to reinstall as you suggest, to see if ’ Create Component’ screen will appear on screen, but thank you now I can continue my work!
Bo

Don’t reinstall. Repair the installation.

Good luck.

I opened the installer and ran the repair and it ended up saying ‘Sketchup 2021 is Ready to Go!’,
but the problem is still there. Could it be some overall setting I by accident has done wrong?. The problem appears even if I open a new project.

Maybe.

Next thing I would do is go to BoHo/AppData/Local/SketchUp/SketchUp 2021/SketchUp and open PrivatePreferences.json in WordPad or NotePad. (or whatever your user is called on your computer.) Do a search for ‘component’. What are the numbers you see? I get this:
Screenshot - 4_8_2021 , 8_39_16 AM

You could edit the file using the same numbers I have, save the file and then open SketchUp and try again.

if you have nothing selected, you need to set the origin (axis) of the component, first. I believe this changed in version 2020 when you could rightclick on an empty space in the model and select ‘Make Component’ (or 'Make Group")

Start making a component, then hit alt and space together, then m, then tap any arrow key, then without clicking move the mouse around until the component dialog appears on screen.

1 Like

Hi Box
Thank you - that did the job!
Also thank you to DaveR and Mike for your help.!

@BoHo If you have the energy to do so, marking @Box 's reply as the topic’s Solution would be helpful to future forums-goers who may encounter this post.

1 Like

Sorry - wasn’t aware of that!