Cannot connect to the geolocation services

Hello,

Working on a 2019 Pro license. Trying to use the geo-location services to create a terrain map. I have been using it extensively for the past weeks, but this morning it stopped working.

cannotconnect

I have read all the tips to resolve the issue, but I’m completely stuck.

-tried logging out and logging to skp account several times
-cleared out Windows DNS cache
-added “Google” to “onlinetesturl” command line in “privatepreferences.json” file
-cleared cookies, lowered privacy setting
-tried changing default browsers to edge/chrome/firefox and tried over
-disabled vpn, disabled firewall, disable antivirus, all of that
-restarted computer

I did everything that was instructed here, and it’s not working for me:

Why did this stopped working suddenly for me? :confused: I’m stuck and unable to the deliver the work that I promised to do today. What do I do?..

Thank you for your time answering.

I’m getting the same message on Sketchup Pro 2021, tried signing out, clearing browser cache and signing back in again, same issue.

    1. You need to log out in SketchUp. [menu] Help > Signout (emailaddress)
    1. Then quit or exit SketchUp.
    1. Start it.

If this doesn’t work, you can try deleting the login_session.dat file that resides in %AppData%/SketchUp/SketchUp 2021 after step 2.

FYI just tested it and it doesn’t work for me. It’s also worth mentioning that it’s a global issue since there are many people reporting same problem.

1 Like

Thank you for the suggestion, tried this as well but didn’t resolve the issue for me. =/

Tried that, doesn’t work for me either,
we need this fixed quickly, it’s stopping our team from producing work.

Yes, I can sincerely say that is the case for me as well, failed to deliver my task today. =(

I’m seeing the same thing in SU2021 this morning, too. I suspect there’s a server down somewhere. It worked fine for me yesterday.

The Status page currently indicates that the Add Location service is working so I expect that the problem lies between it and us.

We see the problem too, and it’s being looked into.

A message has been added to the status page as well.

1 Like

Things seem to be improving, the add location window loads, and importing works. Searching for a street address is failing still.

Address searching is fixed now.

Indeed it is working now for me.