Cannot change a model I found on the Warehouse

I found this model of a bed on the Warehouse but I cannot change it in any way.
Lay+King_Bed_Walnut_SU2017.skp (11.4 MB)
Does anyone have any ideas what I might be doing wrong
I have tried using the Scale tool and also Fredo Scale but it just snaps back after everything I do

It’s a dynamic component once you get inside the top level. You can resize it with the dynamic component Options panel or explode it to get rid the the dynamic attributes.
Screenshot - 12_12_2023 , 1_36_36 PM
If you were using SketchUp Pro instead of Make you could also modify the dynamic component attributets to whatever you want.

Thanks. Exploding it worked. I don’t need to change the kind of things that are options in the Component Options. I don’t normally consider Dynamic Components since I am working in Make

how can I tell if something is a dynamic component

In SketchUp, Dynamic Components have a green DC badge in the Components panel.
Screenshot - 12_12_2023 , 2_38_43 PM

thanks