Can’t paint certain items anymore

New to sketch up and am teaching myself on YouTube mainly but I can’t find a solution to this anywhere.

I’m recreating my apartment as means to have a practice 3D floor plan and I’m currently working on the kitchen. I installed some wall cabinets to and was able to paint them black to match the counters / base cabinets. I then realised I needed to fix some measurements first so I erased them. After getting the kitchen sorted I went to re-install the wall cabinets only this time, I’m unable to paint. Out of curiosity I tried to install different ones and it still won’t let me. I even tried this in a blank canvas and it’s still not working. The oddest part is that the base cabinets are still paintable (even in the new blank canvas). Not sure what to do but it’s very frustrating as I was able to paint before! Help!!!

Share the SketchUp file so we can see what you are working with.

As a guess I’d say you are trying to apply the material to the groups/components but the faces inside the groups/components already have a material applied to them. Materials on faces take precedence over materials applied to group or component containers.

Could this be because you accidentally deleted the outer faces? or is it a Component you are trying apply material directly?

If your model is in component form, you might want to try right click then edit component and try apply material on respective faces.