Can’t Modify a Texture

texture

#1

After using the Paint Bucket tool to apply a texture to a surface of a component, I right click to select ‘Position’ from the drop down menu.

At this point, I should be able to re-position the texture by dragging, or grab the colored pin corners of the texture to rotate/scale/skew/etc. The problem is that clicking on the pins does nothing, and dragging to re-position the texture is difficult to engage. After several clicks, sometimes I can ‘grab’ the texture to re-position it, but do so is very difficult.

I’m running SktechUp 2018 on a Surface Pro with an external monitor and a Logitech mouse. Thanks in advance for any help.


#2

It would help if you attached the model(or a sample model) so what can see what issue you are having.


#3

same problem. I have to delete the surface to get it to change.


#4

I tried to upload the SketchUp file, but at 4.2MB, it is larger than the forum software will allow. I tried zipping it, and modifying it into a smaller drawing, but the size remained above 4 MB.

I’d be happy to email it to you if I may have an email address.

Thank You


#5

Upload it to the 3D Warehouse or to DropBox and share the link.


#6

Uploaded to DropBox. Here’s the link:

Thank You!


#7

Which texture are you trying to reposition and where?


#8

The wavy wood grain on the large panels to each side are an example of where I have the problem.

It occurs with every texture I apply.


#9

You can’t do this?

There’s nothing wrong with the model. I would be looking at your installation. When you installed SketchUp did you right click on the installer exe and use Run as administrator? If you aren’t sure, you could try reinstalling it that way.


#10

Yes, that’s exactly what I want to do, but can’t.

I’ll follow your instructions and reinstall as administrator.

Thanks for your time to look at this.


#11

Make sure you log in with your normal log in but right click on the installer and select Run as administrator.

Good luck.


#12

I just went back again to the model to try repositioning the material just in case there was anything I was missing. One last piece of info to add:

After opening the component to edit, and right-clicking to select ‘texture’, then ‘position’, the cursor does not change to a hand symbol for dragging. The cursor remains a white arrow. Only after clicking several times can I get the arrow to become a hand for dragging.

I send this just in case it triggers a different solution. Otherwise, I’ll re-install as administrator.

Thanks again for your help.


#13

It remains as the white arrow until you left click to grab the texture to move it. See my GIF.


#14

What I experience is different from what happens in your GIF.

After selecting the surface/texture, I then click to get the hand symbol and drag. In my case, that click does not change the arrow to a hand. It simply remains an arrow despite repeated clicks. Sometimes, several clicks later, the arrow becomes a hand and I can reposition the texture.


#15

That’s the sort of strange behavior that makes me think you haven’t got SketchUp installed correctly.


#16

OK.

One last thing I noticed…when everything’s done, and I should have a ‘hand’ for dragging (but it’s still an arrow), if I slide the cursor over any of the colored pins, the arrow turns into a hand while it’s over the colored pin. At that point, I can’t click to select the pin either; it just ignores my click and doesn’t engage. Moving away from the pin turns the hand back into an arrow.

Thanks for your patience. If the best answer remains to re-install, I will do that.


#17

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.