Can not see model and zoom extent not working


#1

https://drive.google.com/file/d/1jyzi65pszqgQXARq65tdp2K5d-ohHrUz/view?usp=sharing

Appreciate if any one can help me with this issue
thx


#2

You have two very long edges on a layer named Carpet

It takes four steps to recover a working file.

  • open the faulty file

  • open the Layers panel and delete the layer named Carpet. Choose the option to
    delete contents

  • paste this line of code into the ruby console and hit Enter to reset Sketchup’s camera

Sketchup.active_model.active_view.camera.set([0,0,0],[1,1,1],[0,0,1])
  • open the Outliner panel, right click on a group and select Zoom Selection, select another group and select Zoom Selection

That did it for me. Hope it works for you.


#3

Great thanks it worked !