Camera position does not follow the eye height setting

I have a building model that has 3 levels. Even after I position the camera on the 3rd level. The eye height goes 20,000 mm height. I correct the eye height by keying in a value of 1500. The camera then takes me to the ground level. This does not seem to be the normal behavior from the Youtube videos that I have seen on this. Please help.

Eye height is the the height above the ground plane which is where the red and green axes default location is. When you pace the camera the camera is placed 5’6" (~1676mm) above the point you click on. If that point is above the ground plane, the displayed eye height will be the height of that point plus 5’6"(~1676mm).

This is the expected behavior. When I use the ‘position camera’ tool the surface on the second floor prompts ‘on surface’. I click on the surface, but the eye height immediately goes 19000 mm. This is what baffles me. Is there some setting that asks it to keep camera datum as the ground only?

Sajit

I’m working on the Bootcamp Roadshow, and this came up in the Boston one, it seemed odd that setting a given height after placing the camera gave a very low view of things. The solution is to set the eye height before placing the camera. Then it becomes, say, 5’6" above whatever surface that is.

1 Like

Here’s a better way to control position of the camera.
Camera Parameters — SketchUp plugin by Bakbek
http://rld.crai.archi.fr/rld/plugin_details.php?id=55

rb

I tried what Colin said, I click on camera for the box to accept the 1500 mm in the box and then place the camera positon on the plane on the 2nd level of the building. it shows 8711 as the Camera position. I measure the height of the level from the ground plane, 6873 mm. It is not the eye level from the ground.