Eye Height and some orientations wrong after model relocation

I worked just fine with my model until I repositioned it, then some weird stuff started to happen and I don’t know how to make it work back again, unless I undo the repositioning (which I would not like).

I rotated my model about 45 degrees to make it compatible with sun orientation and check for shadows, also to make it in position with satelite image (not big deal but nice to help me).

I also raised the model height to try to make it in a sloped terraing like in real life, but I don’t know if I made it the correct way.

I also tried to reposition the axis at the model level and model orientation, but did not solved all the problems.

The problems that arise from this:

When I will use some tool that need Y axis (blue), then it orient to the original position (zero degrees north), I have to move the mouse pointer around to make it orient the way I want (it flicks between the two orientation: zero and 45 degrees). This is commonly seen with the Retangle tool.

Protactor and Rotate tools ALWAYS start from the original orientation of zero degrees north. Even with Axis repositioned.

Section Plane tool also start oriented to original zero degrees north and I can’t rotate it. Like Protactor and Rotate, I can still use it but it is annoying to see it in the wrong orientation of the model AND I am afraid this can cause me troubles in the future, once I use more advanced features in Sketchup or perhaps Layout.

Finally my eye level is not correct. I input 1,70 (one meter and 70 centimeters) and SU always throw me above my ceiling which is much more then 3 meters high. Again I tried to re-position the AXIS tool to make zero heigh the level of my model, but look like it is not working.

Can you help me with that?
Thanks a lot.

Casa Av Parque 3 eletrica.skp (3.6 MB)

Even if you place a new global axis, SketchUp’s system axis remains unchanged, right click an an axis line will show the reset options which returns to the original axis. Many tools relate directly to the system axis only, even after a new axis has been placed. Section planes are one of these tools.

Your eye level is incorrect because by moving the axis you have reset the Z-0 down 347cm. The entered eye height after clicking to position camera is absolute from Z-0. So if you click first then enter 170 you will place the camera at Z +170 from the original system axis. The way around this (unless you want to simply raise your model to true Z-0) is to enter the eye height offset before you set your camera position. Evoke the position camera tool, enter 170cm and press return, then click on the floor you want to stand on. The eye height will read as -200CM or something like that because it’s relating to the system axis but you will be 170 from the surface you are standing on.


Move the entire model so that point is at 0,0,0. Select it all, get the Move tool and grab that point. Start moving it in any direction. Let go of the mouse and type [0,0,0] and hit Enter. Include the square brackets.

You cannot move the origin but you can move the model so the desired point is at the origin. You should probably also reset the axes at some point.

1 Like

I reseted my model to the system axis. :frowning:
Better to design but can’t check the shadows anymore

I usually have a separate file for the house and the site. The house plan being rectilinear is oriented to the axes in the house file. I place the house as a component in the site plan.
Eventually I work primarily in the site plan, and if I have some specific work to do on the house I save the component as a separate file, and reload the house into the site file anytime.

1 Like

Thanks, I have done that.
Is there a command to reorient the model to axis green zero? (system north)?
I am just rotating to align the model with the system axis but it leaves me with that doubt “is it really zeroed to system north?”

Just the Rotate tool.

If the axes are in their default orientation, the solid green points to north. If you rotate the model so the correct line is oriented to the green axis, it will be fine. Probably the best the best thing to do in future models is to start out with the correct orientation so you don’t have to fix it later.

I did the rotation because I wanted to check the shadows in my model. Just because of that.

I wish I could have a way to specify the sun orientation in relation to the model but I don’t have or I don’t know (using free version).

So model in the correct orientation to start with. Save the file and then rotate the model to see. Don’t save the changes.

It kind of sounds to me as if you should be using SketchUp Pro, not Free.

I would love to be using Pro version but I have no money for that right now, I am doing this project to myself.