Camera Clipping Plane (Clipping & missing faces)


#1

Seriously I am bit a at loss of a proper headline, same as to search the forum for similar posts, hence apologies if this a redundancy and in such case thus would appreciate to be pointed to the respective post.

Else have been wondering whether this is a bug or something in the setting, though I tried different styles and perspectives and view port angels, but no avail.

This happened already in SU 2013/2014 and is now still present in SU 2015 (64bit). GPU is GTX880M with 8GB DDR 5 on WIN 7 64bit.

Initial view

zoom in

further zoom in and more back faces appear


View is cut off from certain angles. a bug?
Model Clipping (Camera Array)
#2

Camera Clipping Plane — SketchUp Help
Camera Clipping Plane — SketchUp Sage Site


#3

Thanks for the pointers…

Apparently it is recognised as ‘problem’ but not being considered a serious bug, which needs ironing out? Instead is being justified as design “of critical importance to speedy rendering in SketchUp”?

3rd party rending plugins do not face such trouble, but SU is exhibiting this issue even in Monochrome style.
The workarounds are disturbing the workflow and are no consolation when working with large models.

Why can’t this be fixed, as opposed to pointing the finger to OpenGL?
(“Most of the time, the clipping plane is behind the camera— which is why you usually don’t see it. Sometimes, with very large models (spatially large, that is), it can occasionally slip in front of the camera. This is really an OpenGL issue more than a SketchUp issue”


#4

#5

Neatness does not avoid the bug. It needs to be debugged. As said, other render engines for SU do not exhibit such behaviour, not even in photo realistic rendering of large models.

Wish the developers to iron out this bug.


#6

But model ‘neatness’ DOES avoid the issue.
Modeling miles from the origin, having bits of geometry or guides/construction-lines miles away from the origin, having CAD-block components with origins miles from their geometry etc all contribute to this issue.
Those of us who do ‘model neatly’ rarely see clipping, and when we do we know something is wrong with our model, not with SketchUp itself - so we fix it.
SketchUp is not alone in showing ‘clipping’, it is a common issue in many 3d programs when geometry is excessively big [or small]…
Read George’s link and follow its advice.
Getting uptight about something you can easily do something about, while you are expecting a solution to arrive from on high, is just not logical…


#7

oh, user of a buggy app is now uptight and on top of that being illogical in asking for the bug to be looked at? Seriously, that is now the approach?
I procured the PRO version of the app and paying the annual fee for the right to use the latest and supposedly maintained version (“while you are expecting a solution to arrive from on high”) and now being told to shut up?

There are scenarios requiring geometry to be excessively big [or small] and ‘neatness’ just is not the cure for it.

What is wrong for the asking the developers (“expecting a solution to arrive from on high”) to improve the SU render engine and to get rid of the bug?


#8

It’s more like a limitation than a bug. Everything has limits and nothing is perfect. AutoCad, which has been around forever, has limits too. SketchUp doesn’t really have infinite zoom and therefore does not work well when you approach those limits. SketchUp is ideal for small (a phone) to medium (a very rich man’s mansion) scale projects (in my opinion). If you need to design something excessively small, say an engine part (with accuracy to 1/100th+ of an inch), I wouldn’t recommend you use SketchUp. To blame it on the developers is like me blaming Honda because their Civic made me lose in a drag race, it’s not designed for that purpose. Every software is designed for a target group and purpose, SketchUp has already went well beyond their original purposes and the majority of us are pretty satisfied with its continuing progress.
Sure it’ll can and will get better, but your attitude isn’t right.

And Pro is cheap if you want to compare to other softwares.


#9

It’s not unreasonable to expect the zoom to work regardless of zoom level. The clipping is a technical limitation on our side of the software. It is something we talk about and want to address. It’s just not something that has a simple fix. Until we can find a good solution one has to massage the model to work within the current constraints. Not ideal, I know… :frowning:


#10

blame it on the developers is like me blaming Honda because their Civic made me lose in a drag race, it’s not designed for that purpose. Every software is designed for a target group and purpose, SketchUp has already went well beyond their original purposes and the majority of us are pretty satisfied with its continuing progress.

Was not aware that SU is in comparison what a HONDA is to a pricier brand, so in essence you are saying such things should not be expected for the price. Perhaps would be good to state such limits on the product’s website, for the awareness of the user. e.,g. large scale objects with wee bits of details


#11

It’s not unreasonable to expect the zoom to work regardless of zoom level. The clipping is a technical limitation on our side of the software. It is something we talk about and want to address.

Much obliged!


#12

Wow, way to go on nit-picking my comparison. Fine, maybe I should go, Honda in a race against another Honda, but you’re the driver…


#13

Here’s my little grain of sand: I usually find this problem when working on imported .dwg files. As bored as I am with export-import routines in my daily work, I usually just click through dialog boxes without paying much attention to the units setting on either software. What do I care, if I can simply re-scale the model in sketchup with the tape tool in a blink, right?.. But lately I found that, when importing a CAD, translating milimeters to meters result in extremely large models. Nothing new there. But apparently, when I re-scale those large models to the original meters, the “model space” doesn’t shrink with them. So I end up working in a relatively tiny model floating in a huge nothing… I know sketchup doesn’t really limit the model space, so there’s no way to know how big it is, but at the end, the difference between a rushed import and a “tidy” one is only this: A evil bred clipping plane eating away half my model and all my nerves…

Hope this help!


#14

hi guys! i was struggling with the same problem since some time;

i dont have hidden objects in the geometry
my model is not far from the origin point
the model is not so big, i mean 35 mb is acceptable, right?

i want to share with you something i have discovered: if you have physical cameras created in the scene, just delete them! i realized that this does not make the clipping go away but reduces it significantly. when i need to render, i am just using the scenes. i hope this helps some of you!


#15

We’ve all silently suffered while working around this - and other - limitations of SketchUp. It’s a very efficient software but it comes with a certain level of auto-discipline to avoid some of the mayor issues that can easily make your model into a disaster.

Some of these problems are easily avoided by knowing how to use SketchUp - or even knowing how to draw properly in general (always group objects, make sure you actually snap instead of leaving tiny differences, etc). But considering the Camera Clipping Plane, I’m rather happy to see someone actually filed it as a bug.

It would be very much appreciated to at least have a “purge” tool, or any other way to adjust an incorrect or impractical clipping distance. Even if it’d mean considerably slowing down the software, it’d easily beat the fact that you loose half or three quarters of your efficiency when an impractical clipping plane all of a sudden seemingly magically shows up in a complex model.


#16

Same issue, please fix. I have large geometry due to rural property project boundary sizes and also large imagery for presentation purpose both of which I can’t do without.


#17

Same ol same ol with the most recent release… It was mentioned 1 year ago that the issue to be addressed but it has not. Will it ever (soon) be addressed and fixed? As it stands right now I prefer not the renew my SU pro license and to take my business some place else


#18

New to Sketchup. I’m building a house ~40X50X30 feet. None of the common fixes resolved my clipping pane. It was occurring in one hemisphere, only when I had a group open, and may the software unusable. I copied all my objects and pasted into a new Sketchup file and the problem went away.


#19

Sounds like you had a rogue entity miles from the origin, perhaps inside a group or component.
This could be a short bit of edge, a guide-point etc, and it might be hidden or on an off-layer.
So make sure hidden-geometry is on, all layers are on and guides are on too…

If you follow the steps - select-all and a fence selection to remove everything within the fence from the selection you might have ended with something still selected and reported in entity-info…
Pressing [delete] removes it…

If you imported a CAD drawing that is also a common source of issues…
So never import and keep the CAD origin which might be miles away.
A CAD-block becomes a component, and some CAD-blocks have there origins miles from their geometry, so whilst everything looks to be near the model’s origin, the component is screwy.
You can show the component instance’s origin RGB [aka insertion-point] and use the context-menu to relocate it onto the geometry if needed…


#20

I have the same issue, pls fix.
Neat draftsman overhere, just bound by necessity to use world coordinates due to integration of SU model with different software.