Bug with subtract


#1

I am trying to make 2 holes in a complex shape. I have 3 components, I want to subtract the white ones from the red. I tried all the things I could using the SUBTRACT TOOL (I have sketchip pro) and the result is not what it should be.bug.skp (197.2 KB)

How can I make those 2 holes avoiding this bug?


#2

It does seem not to be working, and like you I can’t at first see any reason why not.

Both your red piece, and the two white cylinders, report as Solid Group and Solid Components respectively.

I select one of the white pieces, use Solid Tools Subtract, select the red group and get only a few stray lines outside the red group, highlighted in the image below.

And this makes the red piece non-solid, so I can’t do it again with the other white piece.

The plugin Trim Keep does the same - leaves fragmentary lines and no cutout.

Certainly not what I expected!

Then I see the problem - your pieces are too small. The cylinders are only 3mm diameter, with too many edges (the default 24) for the size of the cylinder.

Try scaling up by a factor of 10, 100, or 1000 and try again. SU can’t make small edges or faces during the Subtract process.

[LATER] That doesn’t work either.

Perhaps it IS a bug? I can’t see now why it won’t work.


#3

It works when I slide the white piece and try it. I think it might be a bug.


#4

Certainly not what I expect. And when I later tried with Intersect Faces (with the cylinder exploded, and placed in the context of the red piece), I get the elliptical edges on the face of the red piece, but it doesn’t make an opening - and that remains true even when I scale up by 1000x.

So that’s not quite working either.

I had wondered if your red piece had any reversed faces - but it doesn’t. Looked at in Monochrome rendering, all the external faces appear white. (Although, interestingly, SU still thinks it’s a solid after reversing one face.)


#5

If you rotate the cylinder 7.5° it seems to work. I think this may have to do with SketchUp’s problem with multiple loops in a face. Not sure about that part however. And scaling up is most likely going to help.

Shep


#6

I thought it would too, but it doesn’t in this case - I tried it.


#7

Because the ‘hole’ cylinder touches the main geometry at a node-vertex and that is also at a change of plane - at an ‘elbow’, it seems to cause the issue.
Move the cylinders away from the elbow by a small amount and it’ll probably be OK.
Rotating the cylinder has a similar effect, because then the node-vertex is not touching the ‘elbow’ edge…
As illustrated by @Shep
But since the geometry is tiny you could be approaching the 1/1000" tolerance issue as well…
So I also recommend that you Scale everything up x100 [or bigger], do the subtractions and Scale down again…


#8

My friends thanks for your help but it’s not a problem with the scale. I am pretty sure of that cause when I rotate the cilinder in its own axis OR when I move the cilinder just 0.1mm out from the red element everything works as expected! No problems at all, so it really looks like a bug or something reallly weird that I dont know.


#9

Any idea how can I report this as a bug to the developers?


#10

IMO, this strikes me as a limitation of the software, not specifically a bug. As a trainer, it often seems that we aren’t teaching folks how to use the software but guiding them to deal with its limitations in order to get what they want.
Most often, when developing algoritme’s they would use the 80/20 rule in deciding when to stop with going deeper in the (endless) list of opportunities and possible outcome , for it would exponentionally increase the amount of time to do the operation.
If you do want to report it as a bug, try contacting one of the software developers directly or flag the post.
https://www.sketchup.com/team/


#11

Thanks man I agree with your arguments but IMHO sketchup is too buggy. You are right, when training beginners (like me) most people try to explain how to overcome lots of problems (and if this thread is not a bug, it will have to be one more of those things you will have to explain to beginners) BUT THIS IS NOT an excuse to not fix a problem like this. Solidworks has not even 10% of the bugs/issues I found with Sketchup and that I have to overcome with some “hacks” (like scaling model up in some cases).

I think sketchuip developers dont care about the end user, you can easily prove that: in YEARS the software badly received a great update. It’s basically the same software with the same problems, limitations, issues… since Google owned it. in my opinion sketchip is a piece of s*** and most people use it because it’s lightweight (compared to solidwords) and it’s waaay easier to get a PRO edition in torrent websites. Apart from that, sketchup is terrible. The extension store of sketchup is completely buggy, madly slow and nonsense from several end user design overview.


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.