Bug Splat moving component within group

Crash #193589
I have a rather large model, its a chemical plant with tanks and pipes. I had built tag folders to allow specific tanks to be viewed or printed. Drawing in the pipes I have been using the VBO extension for pipes and joints. It sometimes wont allow moving drawn pipes to new locations. I find it is sensitive to layers and names so I mostly leave those native till I’m happy with layout and location. I sometimes will just make a path and a circle for pipe thickness and do a Follow-Me. Then I add pipe joints (90, 45) and trim the corners manually. It is when I move the elbows into place it seems my file crashes on occasion. I try to save often so I don’t loose much.
I do work in a workstation with a redirected mydocs folder. I’m on a laptop and the Sketchup program is local only. My model is about 49mb currently. Not sure what I’m doing wrong, or what I can do to avoid these crashes.


That link goes to some graphics and sound files.

I can’t tell much from the crash report, except that the crash type doesn’t happen very often. Only twice in the last month.

SketchUp was updated recently, are you on the latest version? Here is the most recent installer:


Thank you Colin,
I’m on 21.1.299 64 bit pro 2021
I’ll see if IT can update me.

Program updated but still crashing.
I restarted the laptop after install and openned the model I have been working on and saved and closed and reopened, to make sure it is current.
This crash was moving an object on the z axis.
Bugsplat did not pop up. I did get a pop up.

See if this article helps:

Our It department found this file in the Sketchup program folder. If it is not part of the Sketchup program I can have it deleted. I use Acrobat for pdf files. But is this part of the SketchUp export as pdf feature?

Looking at the info for the file in the Sketchup folder says it is part of the bug splat send report application


Reading the forum I noticed some references to multiple displays as an issue.
I have a dell Laptop
Laptop Del Latitude 5400
Core I5 8th gen vPro 8gb ram
Intel graphics UHD 620
Driver 9/25/19

with a Dell Docker with USB C port connection,
Dell WD19, K20A001

My laptop display is small so i Primarily use me docked displays, 1 hdmi out and 1 Display port out.
And one monitor is rotated 90 to show the tag list on one screen less scrolling.

In the forum many users have reported problems with external monitors, especially when using a dock to connect them. One thing to try might be connecting the external display directly to your laptop.
Updating everyhing might help:Laptop firmware. Dock firmware. Thunderbolt driver. Display driver (yours seems to be two years old) - if no update from Dell, you could try directly from Intel.

1 Like

Installed several updates, So far so good. A little nervous everytime the autoupdate hour glass starts turning.

Crash #196181
Was starting to feel we had it fixed, but crashed again.
I really need the extra screens as my laptop isnot large enough for my old eyes, but I will try single screen today. or maybe direct connect (bypass docker first)
Thanks for suggestions, all are welcome.

Crash #202242
Crashed while inside VBO extension for creating pipes. Was adding a line and orbiting view.

Is there a difference in how many screens you use? Are you using just the external screens or are you using your laptop screen as a third display?

Are you running many extensions? Do you crash if you remove them?

I have a Dock with 2 screens attached and my laptop screen, design was on 2 external screens only as my laptop screen is under 13" After the first suggestions I updated software firmware and drivers. Still crashes, Then unplugged dock and went to 1 HDMI out. Design on laptop screen and tool pallets on external screen. Still crashing, so now trying single small laptop screen :frowning: several crashes have occurred during manipulation of edges involving VBO Pipe extension. I am drawing a P&ID for a chemical plant so it is mostly pipes… I cant pine the issue to the extension as I am preforming a lot of tasks. I try to save inbetween tasks. I havent tried disabling other plugins or extensions. I really need to draw pipes and follow me is too time consuming with all the elbows involved.

Can you just try to remove the plugin temporarily to see if the crashing stops?

@colin , do the recent crashes tell you anything?

I think there are other piping plugins available. And anything that a plugin does, can be done with the native tools.
I think that before retiring, @jean_lemire_1 did similar projects to yours, maybe he would have some workflow hints.

1 Like

I started with sketchup in 2014 ish? and not until this year have I tried Pro. I have mostly drawn houses I’ve lived in and furniture i am building as a hobby. My company asked me to utilize autocad files to make a 3D Model of the plant we are building. I was familiar with follow me and using a circle with the pipe radius, but I wanted realistic joints and elbows and the facility is huge. I tried Steel Sketch at first and it was good, but there were several design chnages nd modifications on that tool where problematic. Then I tried VBO build pipe. It allows for pretty good editing, however that is when I encountered inconsistent issues. Sometimes the pipe disappears and only the edge/line remains. Sometimes the tools redraw feature works, sometimes not. Sometime reboot system helps, sometimes not. Sometimes the screens go black and get a bugsplat, sometimes the crash misses and forced to restart

I’ll try disabling plugins, but adding pipes is kinda the reason for this project. Did you have other plugins to recommend? There are a few I have yet to try.
Thank you.

How large is the model?
Have you gone to the Intel site for the graphics driver? Do not rely on Windows information for the driver.