Bug in smooth surface command?

#1

SMOOTH SURFACE COMMAND MALFUNCTIONING.skp (930.1 KB)

This drives me scatty as it happens EVERY time I try to generate a smooth uniform surface. The shape was made from a single profile meticulously plotted along three curves, then reflected into a symmetrical 3D form. I hit the button to smooth the surfaces and, yet again, the programme leaves hard edges in the model. Why can’t Sketchup cope with a simple task like this? Can’t see what I’ve done wrong!

0 Likes

#2

Have you tried moving the slider.

0 Likes

#3

Neither can we.
Please upload at least a screenshot or… the model

0 Likes

#4

Go to view and untick hidden geometry.

0 Likes

#5

Hi Guys

I’ve put it in the 3D warehouse as: ‘Spog the cabbage’. Attaching stuff to this forum just doesn’t work from this end.

Wo3Dan
SketchUp Sage

    December 20

spogadog:
Can’t see what I’ve done wrong!

Neither can we.

Please upload at least a screenshot or… the model

0 Likes

#6

No, it’s the bold lines that S/U has failed to soften (towards the centre) that are the problem. I know how to toggle the different views, thanks.

0 Likes

#7

You attached the .skp in your opening post, so it seems to work…
open the component, select the edges and tick soft and smooth in the entity info box.
Works for me.

0 Likes

#8

Sorry, i didn’t look very well at first

0 Likes

#9

@spogadog, sorry, I must be getting old, missing that link in your first post.

0 Likes

#10

Slider

2 Likes

#11

No worries. I just redirected folk to the warehouse in the automatic assumption that I HAD screwed up!

0 Likes

#12

Thanks, but what have you DONE here? When I generated this shape I expected it to be flawless on softening, yet I STILL wound up with the annoying four linked edges that ‘refused’ soften.

Nobody has yet explained why this keeps happening; surely S/U should do what YOU have just done by default? There’s nothing wrong with the geometry after all…?

0 Likes

#13

When I opened your file I found most of the edges softened as you expect although Hidden Geometry was turned on so the softened edges were visible. The unsoftened edges along the side of the hull are unsoftened because the angle between the faces is greater than the default 20° softening angle. This is not a bug. It’s normal and should be expected. If you want those edges to be softened, you have to increase the softening angle which would be done by selecting the edges and adjusting the slider in the Soften Edges panel.

1 Like

#14

Excellent! I thought it would be something like that.

O.k, so do I take it that 20 degrees is the angle UP TO WHICH sketchup can smooth the lines between surfaces and still create a passably ‘continuous’ appearance? And that anything beyond that angle is considered too ‘severe’?

0 Likes

#15

You take it that 20° is the default smoothing angle for softened edges. If the angle between is greater, you’ll have to soften the edge if you don’t want to see it.

“passably” is a subjective thing. That’s your decision.

0 Likes

#16

To be pedantic, it would seem there is no way to adjust the value of the angle other than via the slider; i.e: you can’t type a in numerical value? I ask, as I’m finding it hard to get the slider to settle at 30 degress.

0 Likes

#17

The slider is the only way to adjust it and I guess you can’t get too AR about the exact value. I don’t know but it might be possible to write a plugin that would allow you to enter a specific angle. It’s never been an issue for me but then I’m kind of new at SketchUp having only started with version 3.

1 Like

#18

Interpreting ‘AR’ to be what I’m guessing, I can see that the precise angle is an irrelevance when you accept that it’s only a threshold. Hey, such is my joy at finally de-mystifying some ‘Sketchup stuff’ that suddenly need to know the ins & out of a cat’s a**e about it!!

Many thanks.

1 Like

#19

Note that you can use the Erase tool with a modifier key to smooth or hide edges regardless of the slider setting (ctrl=smooth shift=hide).

0 Likes

#20

Thanks, I’ve done that in the past. Fortunately the slider thing is now working a treatEmoji.

0 Likes