Bug in screen text size setting SU 2016 Pro Mac?

I’ve just started to use some Screen Text as a quick way of identifying drawings in SU, without having to bother setting up things in Layout.

When I try and change the size of Screen Text, I click on Fonts, click on the text size I want, then ???

Nothing happens most of the time - the size in the Model Info/Text dialogue doesn’t update to match the selected Font size, but stays stuck at a previous value - for example here the old size got set (by accident - one of the times the setting DID take) at 99pt. I’m trying to change it back to 14pt.:

There’s no OK button to click to confirm the new text size selection, nor does pressing Enter do it. Clicking away from the Fonts dialogue doesn’t seem to do it either.

What am I missing to get the new size to ‘take’? I have done it before, I’m sure, so is it some simple technique I’m missing, or is it a bug that only appears after some period of use?

AHA! I find I CAN change it via the Entity Info dialogue. But why not when I click Update Selected Text in the Model Info/Text/Screen Text dialogue?

John, after you make the setting in the Fonts window, do you click on Select All Screen Text and then Update selected text? That’s the way I’ve done it on my Mac.

I don’t want to update ALL screen text, just the piece I have selected, so I just clicked Update Selected Text, and it (mostlyl) doesn’t do anything. But confusingly, SOMETIMES it changes the size in the upper Screen Text box to match the selection I’ve just made in Fonts, just not always.

Perhaps this dialogue is meant only to change the default value?

Now I have a workaround, I’m less bothered, but I was getting very frustrated until I found that.

I’ll experiment a bit more when I have time, to see if I can reproduce the process that DOES make it stick, and what if anything seems different when it doesn’t, and post back here.

Well, a bit of further experiment.

It seems that if NO screen text is selected, clicking on a Font size immediately changes the value in the upper Screen Text box, as you’d expect, and as I must have done it before when it worked.

But it some screen text is selected, the click on a new size in Fonts does NOT change the size in the Screen Text box.

This may be by design, so you don’t change the default by mistake, but if so, it is VERY confusing when you just want to change one or a few pieces.

On reflection, this does seem to me to be a bug. There’s no warning that you can’t change the font size here when you have text selected, there doesn’t seem to be a good reason why it should NOT be allowed to change the size of a single (or several) pieces of screen text, and it doesn’t work as one might reasonably expect.

How and where do I file a Bug Report?

Or if 2017 will be entering beta testing soon (as I expect from previous experience with Trimble’s timing of new beta releases) should I wait and see if it is reproduced in 2017 too before reporting? They are unlikely to want to retro-fix 2016 at this stage in its life cycle, I would think.

On Windows editions, there is an immediate change in the Model Info > Text > Screen Text default size displayed. (This is what will be used for any subsequently created text objects.)

Clicking “Update Selected Text” button, does update (change) the selected text object.

On a sidenote:

The “Update Selected Text” button looks like it only belongs to the “Leader Lines” control group, but it really applies any of the default changes, to all of the selected text objects at that time.

@john_mcclenahan, do you know if it behaves like this in previous versions of Mac editions ?

Well, just tried it in SU Make 2014 - the only other Mac version I have.

I opened a new file, typed in a couple of pieces of screen text. Highlighted one with Select tool.

Opened Model Info window, went to Text/Screen Text/Font - and CRASH!

So maybe 2016 is better already!

Will try again.

Rinse, repeat, CRASH!.

Will post this, then try complete system restart and try again.

One of the OS X updates introduced a change in text handling that caused SketchUp to crash. Trimble chose not to issue a maintenance release to fix this, addressing it in the next major release instead (I think it was 2015?). So most likely your Mac can not manipulate text in SU 2014 without crashing.

1 Like

Same thing again.

Sent in crash reports for both previous ones. Haven’t bothered with the third.

Memo to self: don’t do this in a production drawing!

Of course, there may be complicating factors at work. Not worth tracking them all down, as I use 2014 rarely, and normally only for testing Ruby scripts in an older Mac version.

Thanks, Steve. I’ll know not to do it in 2014 in future!

What happened, then, to Apple’s older boast that ‘it just works?’ - just ‘until we break it’ as they seem to have done with hi-res support in Sierra?

I’d go back to your first post: when the guy who first developed SketchUp was asked to improve text for SketchUp, you know what he did? Invent LayOut. If you’re doing all this to avoid LayOut, I wouldn’t do that: it’s easier, better, and more precise to do it there than in 3D.

OK, now off the soapbox and to your question: did you update to Sierra or are you still on El Capitan? El Capitan came out AFTER SketchUp 2014, so be aware of that, just as Sierra came out AFTER SketchUp 2016. How can I find your crash report - please PM me, or put my name in the description of your crash.

Well, SU2014 is not going to be fixed, so let’s concentrate on the 2016 bug where selected text is updated on Windows, but not on Mac.

My question about previous versions was only to divine whether this is a “new” bug for 2016.

I’m still on El Capitan, and not planning to update to Sierra until the SU forum reports that issues are all fixed.

And I do understand that SU 2014 came out before El Capitan, so they are not designed to play well together.

I still hesitate to use Layout only because the learning curve is significant, and because I don’t need ‘professional looking’ drawings for what I mainly do - quick working drawings for scenery construction, which often get revised more than once. All I really need is some screen text to identify the drawing, the date it was drawn, and perhaps a revision number, and key dimensions. SU dimensioning is ‘good enough’ for that, in the kind of work I do.

If I were (like Steve) doing professional cabinetmaking with a need to make presentations to clients, I’m sure I’d invest the time in Layout, and in using materials, images and textures in SU and transferring models Layout for presentation, like DaveR. But for getting it ‘good enough’ for half a dozen other retired colleagues who enjoy making scenery, and get together mostly once a week for work and a quick pub lunch, SU with a few printouts to PDF does it well enough, and quickly.

And the other major limitation of Layout for me is that its dimensions are not associative - so if the SU model changes size (at least as I understand it) you have to reposition all the dimensions drawn in Layout. If that changes in a future version of Layout, I’d find that really encouraging and would probably try it again.

And the SU dimensions themselves go very peculiar in Layout - the text size jumps dramatically in size, as do the arrows, as I recall from one attempt to use Layout on an already drawn and dimensioned SU model. (I posted here about it, some time ago.) It became effectively useless to have done the dimensions in SU, as they wouldn’t stay looking the same in Layout. Possibly that’s a result of difficulties SU and Layout have in dealing with high res screens and/or text handling?

I hardly tried Layout when I was still using a Windows 7 machine with a Full HD screen (1920 x 1280 from memory), so I don’t remember if there was the same problem with dimensions not transferring well from SU to Layout without any ‘hi-res’ complications, if that indeed was what caused my problems with dimensions.

If I had more time to invest in Layout, and a more pressing reason to, I’m sure I’d enjoy learning more about it. I’m far from Luddite, and very much enjoy learning new stuff. But there isn’t for me any great drive or necessity to improve the presentation for the current group of users of my output - it might be nice, and give me some sense of achievement to make it look ‘more professional’ but nobody would really care much if I did that!

At them moment, they all think it’s magic that I can draw in 3D and show them the results! Several others have tried, both with SU and other programs, but no one else at the Theatre has got very far with learning SU.