Blurry display in SketchUp Make 2017

I am having to stay with the 2016 version of SketchUp Make due to having a blurry display with 2017.
I assumed that the problem was due to my 2015 vintage HP Pavilion desktop PC having its graphics facility integral with its main processor BUT when I ran the SketchUp Checkup app, the results showed ‘Success’ in all sections (including the Open GL requirement).
I have downloaded the latest graphics card driver from Radeon but still no improvement.
If I do need to install a discrete graphics card, can anyone suggest a suitable (cheap) one, bearing in mind that I only do small hobbyist projects.
Thanks
Peter

It is impossible to say. Are you running your monitor at a non-native resolution? Is SketchUp using your Radeon graphics (Window menu>Preferences>OpenGL>Graphics card details)? If not you need to go to the Radeon control panel 3D application settings to change. What is your Antialiasing setting (window menu>Preferences>OpenGL)?
When you make changes to these settings, you have to restart SketchUp for them to take effect.

Anssi
Thank you very much for your detailed reply to my query.

I have tried to follow your suggestions but, being very limited in my understanding of the technicalities involved, I am not certain what I should expect to find.
Therefore, I have taken a couple of screenshots of the Open GL settings and Graphic Card Details dialog boxes so that you can check if everything is in order.

I look forward to your comments.
Peter

OpenGL Settings.jpg

Graphic Card Details.jpg