Black Edges Appear when I try to walk through my file... even though I have edges turned off

sketchup
render
advice
edges

#1

I am making a ballroom scene for an events project and have the edges and back edges turned off on the file. I would like to take a screen video walking though the file to show it in all of it’s 3D glory but when I go to walk through the file the black lines appear around every single item in the file. When I stop moving they go away again.

Please help!!