Black Boxes, Exported Images With Text II


#1

Well, I’m still getting this garbled text in exported images. I went fro 2016, to 2015 hoping it would solve this but it didn’t …

this was my first thread about it Black Blocks In Text Exported Images

we couldn’t resolve it that time, and probably can’t this time, I even worked with SUp support and they had nothing to offer except to ask me to post the issue here,

so where else can I get some help with this? It’s quite a hassle for me!

I’m on Win 7 with a very decent computer now, but this did start happening when I got this new computer, and went from SUp ver 5 to 2016, and now 2015.

Is there a Windows graphic forum where I could try and resolve this??

darn, how do I post the images I have?


#2

OK, this is how it should be

and this is how it is exported

It was doing this when I had hidden the leader, but as you can see that doesn’t matter now, hidden leader or not …


#3

HI Joe. To upload images click on that little icon at the top of the text box that looks kinda like the Push/Pull tool. Sounds like a graphic card issue to me.

Edit: I guess you found it. :wink:


#4

hey Alan! Real good to see you again!! Oh what great time we had at the old @Last forum hey?

how do I troubleshoot the graphics card? I updated the driver when it first started happening, and a time or two since.

This is my setup now-
I have a GTX 960
Intel Core !5–2500K CPU
8 GB Ram
using Win 7 Ultimate


#5

Making the texts a Group has been known to help.


#6

If you right-click your desktop you may get a menu that includes graphic options. I get a link to the NVIDIA control panel. There may be some options in there that could help with your problem. Just make sure you make a note of any changes, so you can undo them again, if necessary.

For instance, I turned anti-aliasing on for SketchUp, but found I didn’t need it as the edges weren’t jagged to begin with. All it did was anti-alias the halftone pattern you get when you select a face into complete invisibility.

If you have an AMD card or an integrated Intel card, that might be the problem. But I can’t say I’ve ever come across that particular problem with integrated graphics.


#7

Does it happen with all fonts, or only certain fonts ?


#8

Control Panel > Display

Set to 100% ?


Check the Clear Type setting. On or Off ?


#9

Yeah, Grouping I’ve already tried Geo,

I tried changing a few of the graphics card settings Alan, didn’t help, I can try a few more though.

Dan, I tried different fonts, I still get the black boxes but in different parts of the text each time. Maybe I can find one that works though. My Display was at medium 125%, tried the 100% and that didn’t help. The Clear Type was on, turned it off but that didn’t help either …

boy I really appreciate all the good suggestions people!


#10

Do you have Pro ? Just wondering if the scene was exported to LayOut, if an export from there has the same issues for you ?


#11

Yep I have Pro, but you gotta understand I’m coming fro SUp Ver 5 for the last 15 years so haven’t learned Layout! I’m still a basic SUp guy.

I’m willing to try it though, can you point me to a Layout tutorial, for scenes such as mine??


#12

Get this free extension from the SketchUp Dev Team: Create LayOut File

It is easiest to open the EW from inside SketchUp via:
Window > Extension Warehouse

Then either go to the SketchUp Team store page, or just search on “Create Layout” (not case sensitive.) Click the red Install button to have the EW install the extension for you.

Follow the instructions on it’s EW product page, for how to generate a .layout for your model.


then:

LayOut User Guide

and:

Video Tutorials: LayOut


#13

Right on Dan, I have some reading to do!


#14

I am having the same issue as JoeFromSDiego with SU Pro 2016. It seems to be random, I tried to isolate a cause with no luck. Example: with everything being even I exported the exact same view twice with two different results (the black boxes showed up on one but not the other even though I changed nothing between exporting jpgs).

Joe- Did you find any fixes/workarounds besides using Layout?


#15

Nope, I kept having the same black boxes for awhile then didn’t use SUp for a couple months. Just tried exporting some images tonite with no problem at all :slight_smile: and this is with a computer with a 2TB storage drive with pending bad sectors (and now I can’t access the partitions on it). So it works fine now but I wouldn’t recommend using this fix for your problem :slight_smile:


#16

Oh and still haven’t tried Layout …


#17

OK folks, I have a much better computer and graphics card, but am still getting these black boxes in exported images!

can we try again to figure out what’s happening??


#18

Hello Joe!

Glad to see you here - I had missed this thread before.

One thing I think hasn’t been asked: Does changing the export resolution have any effect on this?

Anssi


#19

Yes! I’ve been exporting at 6000 pixels wide, tried 2000 and no black boxes, but then tried 4000 and got the messed up text again!!


#20

Have you tried SketchUp 2017 yet?