Black Blocks In Text Exported Images

Using 2016, when I export images with Text on them I frequently get these black blocks in the text (look at bottom right), sometimes a lot worse then this. What’s the issue, 2016, or my graphics card settings / whatever??

here’s the image…

Is this in SketchUp or Layout?

SUp Dave, I don’t use layout.

Before you get into the graphics card settings… I think it’s worth looking into the font that’s being used here.

What’s the ‘text’ suppose to say, behind the blackout. . . and what’s the chosen font, and it’s size currently set to?

The quickest fix could likely be a simple font change, along with a slight increase in the size… but then I don’t know what your settings currently are.

Also, you have that call out text set up with an underline setting. Have you tried it without that in place.

Oh I’ve already tried to change the font, didn’t help. Here’s another example, and the skp file

1 Example Corner_Connections.skp (469.4 KB)

It mostly happens when I hide the leader, but it also happens when I don’t hide the leader.

I’ve turned off Use Hardware Acceleration and Fast Feedback. Tried grouping, then ungrouping the text, tried exporting jpg, tff, and png, all same result.

I tried exports with leaders showing and also hidden. I can’t make the black box show as in your first screen shot.

Just for reference… I export the following.

I also can’t duplicate the blocked out text, or the other clipping problems in your 2nd’ attachment.

Have you experimented with different SU Styles, and camera settings at all?

What are your computer specs looking like? SketchUp 2016 running on… ???

No I haven’t tried different styles, or camera settings (FOV?) , but I do have diff styles with diff models , and this happens with every image (with text) I export.

I have a GTX 960
Intel Core !5–2500K CPU
8 GB Ram
using Win 7 Ultimate

The fact that so much of the text DOES turn out okay, makes it hard to believe it’s a graphics card issue. But I’m starting to become a believer. :slight_smile:

The other issue in play here might be a matter of running the latest version of SU on an older OS. I’d be curious if you had the same results on a version of SU that was a closer build version to the Windows 7 days, and the typical hardware that was around during that time.

This would be asking a lot of your time… on a suspicion of mine that might not have a lot merit… so it’s probably best to wait for some other folks feedback on this one… unless of course you’re sufficiently curious yourself, and have some time on your hands to run the experiment.

It does look like you jumped from SU version 5 to 2016. That leap in itself is probably deserving of numerous updating awards. and possibly a few procrastination achievement badges. which I’m envious of in case you were wondering.

You started your first thread with the hunch that this might be a graphics card issue… so I assume that you’ve also probably looked into updating your graphics card drivers already… and I only mention that now as a matter of covering the complete trouble shooting list as it were.

I wish you luck with this. and I’m sure a solution a will be found here. For the time being I have to head off and get some work done for the day. I’ll check back when thats all over with and hopefully will end up reading about how you folks have all solved this problem. if not then I’ll try help out once again.

Take Care,


Right! FOV settings, or perspective were what I had in mind in the comments above.

What is this Test you mention Jim?

yes, updated the driver.

I don’t like 2016 at all, especially the trays and of course this text issue. Which older version would you suggest I go back to?

I’m getting similar looking artefacts in Sketchup Mobile Viewer - see my earlier post at

1 Like

Hey Jim, in your first post you said ‘you have that call out text set up with an underline setting’,

do you mean underlined text?

John M, have you contacted Support about this? Maybe if you do they can find similarities in our problem?

Right, I just saw that the only text that was blocked out in your first screen shot happened to also be underlined—when nothing else was—so I wondered about the relationship there.

It was the experiment of trying an earlier version of SketchUp, in order to see if it had the same problem.

I’m not sure, at least in terms of making a recommendation. But in hedging your bets on this, I guess it’s probably best to step back as little as possible.

I use SketchUp on a Mac, and we didn’t have the trays pushed onto our version (and of course some folks didn’t like that because it went to show that SU for the Mac is lagging behind the SU Windows version). But it’s my understanding (and memory), that these trays were new to SU 2016. . . and as such I think SU 2015 might be enough of a step back to get rid of them.

SU 2016’s BIG improvement or win came in the form of a completely revamped inference system. So in deciding IF you’re going to roll back to a pre 2016 version than at least make sure that you know what you’re missing out on in terms of that option as well.

Otherwise 2015, or even 2014 both have a pretty similar feel from my perspective. whether or not they suffer from this text issue I’m not sure.

Access to some of the recent versions are available here. . .

You can run these side by side, so I would say don’t uninstall the new version just to test out a previous one.

I don’t like the crazy inferencing in 2016 either, so,

tried 2015 and no issue with the black boxes :slight_smile: so far.