Bitmap to mesh thowing error when attempting to load image @thomthom


#1

I installed the latest version of bitmap to mesh via the sketchup extensions store, verified that it had been installed and enabled and that the latest version of TT_Lib2 is installed and enabled.

When clicking draw/mesh from heightmap, I get a select image window, I select the dem02_original_100.bmp, select the plane, image loads, then select the height. At this point an error box appears and I am stuck in select the height and have to restart sketchup (error shown below). I am also unable to get my bitmaps to load, just get the same error box as before, with no hangups. Any ideas?

Wasn’t sure where to put @thomthom to get his attention, so put it both here and in the title.


#2

Did you fill in the description field and click Report button on the error window?


#3

Can you attache the image you tried to use?

Also:

Did you submit it? If so, can you PM me the name or email you used so I can look up the error?


#4

Sorry, had some things going on and couldn’t respond sooner. Just tried it with a different image, and got the same error. piper-pa-18-super-cub-1.bmp.zip (16.3 KB)

Had to upload bmp as a zip.


#5

What did you use to create this bitmap?

SketchUp isn’t able to recognise it. Looks like perhaps it’s a 1bit format?


#6

Gimp 2


#7

Yes, it is a bitmap (black and white).


#8

Btimap to Mesh uses SketchUp’s API to load the images. When you cannot import the image into SketchUp itself then the extension cannot do so either. I’m adding better handling of this scenario to message that the bitmap format cannot be read.