Trying out Mesh from Heightmap

I am trying to use Bitmap to Mesh to make a mesh from a heightmap like the following video shows
Instant Terrain from Heightmap - YouTube

I saved a heightmap from Tangrams. Since the only file type Bitmap to Mesh was looking for were .bmp, I saved it as that. But whenever I try to pick a depth, I get an error.

These are the two screen shots I can take. I cannot send the file, since when I save it, it doesn’t save anything

Also I do I figure what the depth of the heightmap should be?

Sorry How do I figure out what the depth of the heightmap should be

I’ve not used this extension, but usually “out-of-the-box” in SketchUp, a red bounding box indicates that a group or instance context is locked.

Maybe if you share your original heightmap image we can see if there’s something related to it that is problematic. Or maybe it’s your workflow or your hardware?

As for setting the height of the mesh, you need to know what the difference between the low and high points in the map are supposed to be.


This is the original that I Saved As a .bmp

It worked for me.

There’s a bright edge along the top of the image that resulted in a vertical face in the messh.

Cropping the top few rows of pixels off would get rid of it, though.

every time I try I get the error message. Could it be that it doesn’t work in 2017?

Unlikely. The compatibility list indicates it’ll work with all versions back to 2014.

Try a simpler height map and see if that works. Maybe this one.

How would I get a simpler heightmap?

Try the one I gave you. Or crop one down.

I tried it and it still gets an error. Is there a way to make mine simpler besides resizing it.

HM cropped

See if this one will work.

I’m guessing it’s your hardware since there doesn’t appear to be anything wrong with the extension.

But changing your map to .bmp made it larger. Do you know any way to use a .jpeg in 2017. I will try it

Don’t change it to .bmp. I just used the .jpg and it worked fine. It also works with .png files.

When I open Mesh from Heightmap, it only has the option to find .bmp. I think I agree with you that it is my hardware

The extension will accept any of a number of image file types.

This is what mine has

I just installed the extension today. Have you had it for a long time? Maybe it’s been updated.

I installed it 2 or 3 weeks ago, and have never been able to get it to work without the error

I just decided to really work with it today and ask about it