Bitmap as background with Vray

Hello everyone,

I’m new to this blog and I’m hoping you can lend me a hand. Here’s the situation: I’m trying to add objects to a photo. I’ve successfully inserted the photo and adjusted the model to closely match the background image. Additionally, I’ve created a matte material to project the shadow. However, I’ve encountered a problem: the 3D objects I’ve added appear transparent, and I’m unsure why this is happening. Any assistance would be greatly appreciated. Thank you!

(the chairs anche the table are the objects)

If you have used the Match Photo function, turn off Foreground Photo in the settings.

Thanks for the quick answer, but i don’t know in wich setting you mean.
maybe here?

I thoughr we were looking at a SketchUp Match Photo scene. My V-Ray isn’t working at the moment so I cannot try which V-Ray settings should be changed. It looks like the photo is in front of your scene instead of behind.

Did you insert the picture in V-Ray > Environment > Background?
Or did you use Match Photo from SketchUp?

You actually used a Wrapper Material for the shadows?

I used Match Photo and a wrapper material for the shadow applied to the infinite plan and to a rectangular where the paint is.
Casa_Fotoinserimento_V3.skp (5.9 MB)

Missing image file

Anssi’s advice

sorry, i forgot the image for the background…

After checking the two settings

Wrapper Material tutorial

Turn off Progressive.

1 Like