Bezir Surfaces from Curves extension - no chance to get it working


A few days ago I´ve bought “Bezir Surfaces from Curves” from Jakob Samuel.
Downloaded / Installed in SU 2023 Pro throught the Warehouse, but the extension is greyed-out.
The extension Manager says "active2, but at the same time it tells me with a red button to “update license”, which doesn´t do anything.
I´ve tried everything, uninstall and re-install, always closing the SU application, restart the computer aso. The warehouse tells me 1/3 activations, but I´m quite sure it has something to do with the license. However, I couln´t bye another license because the Warehouse just offers the install button.

I´m out of option, but would need the extension to complete my model.



Try contacting the author directly and see if they can help.

this was the first thing I did…

Here is the response from the author:

Hello Ralf,
Sorry about the delayed response and to hear about the trouble you are having.
Unfortunately, I cannot send the rbz file as I have no idea how the licensing of the extensions work.
I cannot even generate the rbz that includes the licensing information myself. Only SketchUp can do that.

OK. Have you tried contacting SketchUp Customer Support?


But log-out/ log-in didn´t help and re-installing the extension I´ve already tried several times - no change.

pourquoi ça ne marche pas !!!

Please try to explain what your problem is and update your forum profile with useful information.
That information helps us to help you!!

le problème c’est que au lieu d’avoir the red shape quand je clique entré reste the green shape je pense le problème réside dans la position de la 1ere ligne

Maybe because you’re using the free version that doesn’t allow plug-ins installation.

Is this about the plugin in the title or something else?

yeah… Either write french or english, but if you switch every two words, no translating tool will manage to do its job :sweat_smile:

The problem is that instead of having the red shape when I press enter, the green shape remains. I think the issue is in the position of my first line

:fr: Tu utilises la version Pro en version d’essai c’est ça ? attention, dans ton profil, tu as noté qu tu es en version gratuite, la version gratuite est en ligne.
Aussi, ce serait bien de renseigner ton os (mac, pc, quelle version), et ta carte graphique, histoire que l’on sache avec quel matériel tu bosses.

:uk: asking clarification about their profile, I’m guessing it’s pro trial, but no idea whether it’s PC or mac or…

Besides the useless information in your forum profile and lack of description in your post, your screenshot shows you are using a different extension than the one this thread is referring to. Your screenshot shows that you are using Shape Bender and you need to press either the up or down cursor key.

As requested, please correct your forum profile.

1 Like

SketchUp is not compatible with the “4” operating system.



Did you ever manage to resolve this?
I have Bezier Surface of Revolution extension by same author. And I have the same problem as you…Extension under Draw menu is greyed out, and I have tried all the suggestions here as well.