Bezier Patch 1.1 plugin not installing

Hi I have tried several times to load the Bezier Patch plugin found at Sketchucation & Ruby lib.depot. I have tried to mimic the instructions by the designer given in the Sketchucation forum. all without success. Instructions state to enter a command in the ruby editor.I cut&pasted the script from the post but it returns a Syntax Error 158 etc etc

. Has anyone had luck installing this plugin? If so, how did you do it and what Version did you install it on? I managed to get Bezier Surface to run on SU 8 but not SU 7 despite several attempts. I would like to try them both out they appear to work quite differently. Thanks JRT

You should add some links to the used plugins…

SU7 is way beyond end of life. No one would support it anymore, especially since SU8 fixes many of it’s bugs.

Generally speaking the scripts at Ruby Plugin Depot are obsolete, when compared to those releases at SketchUcation or the Trimble Extension Warehouse.

“etc., etc.” will not help as it is omitting the most important part of the error message.
“158” likely refers to the line number within the code, where the error occurred.
BUT the tool consists of multiple files, so we have no way of knowing which file the error occurred in, because you did not post the complete error message.

Pls do so, wrapped in backticks (ie, ` chars.)

If this is a very old thread, circa v7 or 8, the instructions are likely obsolete. Late in the v8 cycle a new extension archive (.rbz files,) was introduced. They were installed via the “Install Extension…” button on the “Extensions” panel, of the “Preferences” dialog.

You should use the RBZ archive from the SketchUcation PluginStore product page red “Download” button link:
http://sketchucation.com/pluginstore?pln=bez-patch

Then open Window > Preferences > Extensions, click the “install Extension…” button, browse to the place where you downloaded the RBZ archive, and choose it, click OK. It will copy the files where they need to go.

That “Tool” is very old and does not follow extension best practices. It needs an extension registrar script in the outer “Plugins” folder, so it can be switched on and off:

I whipped one up, (but it will not solve any errors in the other files.)
ngon_bezier_patch.rb (1.7 KB)

1 Like

Thanks Dan, I followed your instructions and I finally got bezier patch up and running. Both bezier patch and bezier surface seem to be a bit buggy. Bezier surface has crashed the two times I have played with it, so I am not sure how useful they will be. Both seem to have limited functionality, nothing like the fluidity and ease of manipulation of nurbs surfaces/objects in Blender. But at least I have them installed and working. and anything I can generate I will be able to easily export. These appear to be the only two apps for bezier or nurbs surface generation on SU. Thanks for all your help. jrt

have a look at SubD and the other plugins that came along after bezier patch…

john