[SOLVED] Why Can't I Install A Plugin on My Sketchup?


#1

Hello, I’m kinda confused about installing plugin .rb extension on my sketchup pro 2015.
The plugin’s name is muvizuaseexporter.rb
It’s to export file to Muvizu extension.
I’ve tried to put this file in win7/program files/sketchup/sketchup 2015/tools
I’ve also tried to put this in win7/users/nenene/appdata/roaming/sketchup/sketchup2015/sketchup/plugins

The problem is like :

Please help meee :confounded:


Error Importing from Sketchup (Muvizu)
Forum Zoom on Android
#2

How old is the extension? The Ruby version used with SketchUp extensions was upgraded with version 2015 (or was it 2014?) and that made many old extensions obsolete. Is there a newer version of the extension available?

Anssi


#3

I have widows 7 and the install path is: root directory is winC… just paste the rb into that plugin. You still have to make sure the plugin is compatible with the API per Anssis note.
Make sure you cleanup the bad install paths.


#4

The first path is wrong, you are not supposed to put anything there, it is reserved for things belonging to the SketchUp application itself.

Anssi


#5

I had a quick search for issues and found a couple…
after changing the encoding, replacing the tabs, fixing the 8 fatal errors I ran a ruby lint plugin and got this…

1 file inspected, 5251 offenses detected

it is fixable, so maybe you should contact the author and suggest that they run rubocop on it…

john


#6

Oh okay…I was so confused so I followed every tutorial in Youtube :grimacing: Thank you anyway!


#7

Thank’s! I hope I can get new link for Muvizu exporter as soon as possible :sweat:
It’s an old plugin I think, so I can’t run it on my newer Sketchup :sweat:


#8

I think it must be an old file :disappointed_relieved: I don’t know where to find the newer plugin version for exporting into .ase actually.


#9

I’ll try it :grin: Thank’s!
I don’t know where to find another newer plugin actually.
I’m currently working on my short animation on Muvizu…without this plugin I can’t import from Sketchup :disappointed_relieved:

I have searched on Google and no newer plugin version.


#10

If you have an older version of SketchUp, you can use it with that old plugin.


#11

I can’t promise this fix makes it work in newer SketchUps [I’ve not tested it], but it will allow it to load successfully…

In the line #883 [indicated in the error message] there is a space between the method and the opening parenthesis around its arguments:

continueResult = UI.messagebox ("You have selected the same component for the geometry mesh and the collision mesh. This is not recommended, do you wish to progress?", MB_YESNO, "Are you sure?")

Remove that one space, save it, and it then loads OK…

continueResult = UI.messagebox("You have selected the same component for the geometry mesh and the collision mesh. This is not recommended, do you wish to progress?", MB_YESNO, "Are you sure?")

The newer versions’ Ruby is not so forgiving of this kind of simple typo error.


#12

@TIG, where did you download the ruby from?

the version I found has fatal errors for all the file write paths because it uses

"C:\u..."

in the filenames which is seen as a unicode escape sequence…

john


#13

The only file-path in the RB I downloaded is correctly escaped as:
a_pTexturePath = "C:\\ut3\\toto.bmp"
and of course that subfolder/bmp etc will need to exist [it’s where the file(s) go etc]…
All of that is explained in the itemized list in the link below [item 4 and onwards],

I got my RB off here ** https://www.muvizu.com/Forum/topic1452-sketchup-to-muvizu.aspx?Page=10
[it needs the fix at one line #883 - as I indicated earlier…]
Here’s the direct download link:
http://www.muvizu.com/download/muvizuaseexporter.rb

There is also ‘HSKP2UNR_MUVIZU.rb’ linked in the same thread [ ** ], and that RB does have the non-escaped \ errors !
However, if that’s the file you meant, it’s NOT the same named RB as the original error message - it’s much longer and it doesn’t have the problem code at the given line #883 either…


#14

Where should I write this code? I’ve tried the one you recommend me @TIG


#15

This what I’ve got after I typed the error on Ruby Console :


#16

Edit the script in a plain text editor. Notepad++ is a good one.

Open the plugin in the editor and make the corrections as given above. Then save the file. If the place you saved the file to is SU’s Plugins directory, then you just have to restart SU.

OR, if you don’t want to keep restarting SU, in the Ruby Console, type:
load "muvizuaseexporter.rb"
Press Enter on the keyboard. The response in the Ruby Console should be True.


#18

Thank you all!
Finally it got installed on my sketchup!!! :laughing: :laughing: :laughing: