Benchmark for SketchUp

Only just realised that this benchmark existed! Frames per second with original settings in the file: 31.5922.

After I turned off shadows and chose the style Shaded with Textures: 60.5306.

I’m confused why SU included shadows and a more resource intensive Style setting to begin with. You’re already slowing the file down. I never use shadows and always use Shaded with Textures anyway.

This clearly shows how efficient workflows definitely optimises SketchUp :slightly_smiling_face:

Spec (5 years old!):
Dual Intel(R) Xeon(R) CPU E5-2630
64GB RAM
NVIDIA GTX 980i

Benchmark

60 fps is pretty good. Of the things that are on by default, that slow down performance, Profiles is one of the worst. Turning off Profiles can make a big difference.

100%! I advise my students to use the ‘fast modelling’ styles all the time, particularly Shaded with Textures!

There are no special modes in SketchUp, you always work in the ‘endresult’ or editing mode. So adjusting the render style has great impact on performance

1 Like

Fair point. View size: 1893 x 913. Anti Aliasing is set to 0.

Totally! I always knew that but I never had something ‘tangible’ ro prove it (until now!).

Just set up a new laptop… a modest Dell Inspiron with integrated Iris Xe GPU.

image

Inspirion 15 5510
i7 11390H
16GB RAM
Iris XE (shared memory)

Completely stock with no setting changes, and at 1080p native display, default Sketchup 2021 install with 4x AA.

Im impressed by how smooth this feels. I made 84 duplicate copies of the Test Time Display sample model, and it still feels smooth and gives 11-12 FPS during the test. Compared to my laptops with dedicated GPUs, this one keeps the shadows visible instead of hiding & recalculating them as I orbit - it’s a nicer experience.

But there is an error with the text overlay that I haven’t seen before on other systems…

I might do a bit more testing if anyone is particularly interested, but for now I’d say the performance of the Iris Pro is good.

As a reference, my “workstation laptop” (an older i8750h, 32gb DDR4 and 1070max-q) scores about the same in this test.

Drivers/stability is untested but that overlay bug worries me slightly.
Also, since the Iris XE shares system RAM, you will want at least 16GB total RAM in the laptop, but 32GB wouldn’t be overkill if you run lots of Chrome tabs and sketchup windows + LO.

Do you have Fast Feedback on or off? (Window menu>Preferences>OpenGL) Most integrated graphics don’t support Fast Feedback.

any reason why this?
would at least use an AA of “2x”, better “4x”… more doesn’t help much more.

With Retina displays lines are already not very jaggy. You can see changes with 2x and 4x, but not enough to be worth giving up performance.

For the benchmark test though, Profiles and Shadows, and 4x AA, ought to be on. Then it’s a fairer comparison between different machines.

1 Like

When I go beyond 0 the edges become blurred on my screen. I’ve tested it.

It has to make sense, Colin. I don’t need to increase AA. When I do, my edges become less sharp. No one I know models with profiles and shadows on. We should be using real world scenarios so that the test is meaningful.

In case anyone is interested in how my edges appear depending on AA settings!

I think that your image has been scaled, leaving the otherwise sharp 0x lines looking blurry.

The antialiasing does effectively blur edges, it uses grayscale value to make the line seem smoother. Here is a close up of what 0x and 8x look like:

0x

If your monitor was not as high resolution, the stepping of 0x would be a distraction.

Even with me trying to get sharp jaggy lines, the screenshot came out slightly smoothed. The system itself tries to smooth lines as well.

I’m confused, why would I want blurred edges?! I had to scale the images to get them all on the page, I can send you full resolution. You can still see the difference, though!

Screenshots with no scaling!

Here is a closeup of your 0x image:

image

and 2x:

image

Some people prefer the reduced stepping, but using other grays, than the sharper steps in 0x.

As I was saying though, on a Retina screen the stepping is hardly noticeable, unless you zoom in like I did.

I see you are on Windows, there the screen would be referred to as HiDPI.

1 Like

But I’m never going to look at my plans/edges that close on the screen. Even if I print out/want better quality, I’m sending them to LayOut and choosing Hybrid mode and then exporting to PDF. I personally find it very off-putting looking at my plans and visuals with parts of them slightly blurred. It’s like I’m looking at them under water!

New Computer!

Sketch Pro Windows version 21.1.332
Core i7-10700T CPU @ 2GHz, 1992 Mhz, 8 Cores, 2 Logical Processors
Graphics: NVIDIA Quadro P1000, 1GB
Windows 10 Pro version 10.0,19042
Shadows ON:
image
Same System, Shadows OFF:
image

I’m only setting up this computer right now - it’s going up to my vacation property/future home in a few weeks, so I’m NOT changing my forum profile as most of my work will be on my OLD computer.