Begins from unexpected file format to can't open the file

I have built a model for the past year for my final project and successfully save it into a .skp file everytime. However, yesterday i began to receive notification for autosave failed whenever i want to save it. After trying to resolve it by going to preferences and change the location still cant save the file and finally bug splat happened. When i tried to reopened, i couldn’t open it and thinking maybe because i change the location. And tried to download SU Pro 2021 hoping it works(using SU Pro 2019 before) I reopen it, I got an “Unexpected File Format” error. I tried everything I know, including importing/renaming etc but the error still exists.

Is there anyone who can help me find why it happens, and even fix it to normal? I’m very desperate for this since this is my final project that i need to submit tomorrow and i’ve worked on this model this whole year. I still can see the preview from the thumbnail and believe the files can be repaired. I attached the files below, please help me, thank you in advance.

Please don’t double post, you are already getting help in the other thread from the only person here that can help you.

Sorry, but as you can see i’m desperate as the help didn’t resolve the problem. I won’t bother to disturb anyone if i can solve this by myself. Thank you