Beginner - Sketchup "code review"?


I’m a C# developer and spend 1 week on sketchup, trying to furnish my house.
Below a link to my project (sorry for sketchy link - no pun intended)

On the surface things seem to be going well but I’m pretty sure that I’m making some basic mistakes. Really interested to know what you guys think - like a code review?

For one, navigating my project seems slower than I would expect…
And I haven’t grouped anything, started with some “Tags” but I don’t really know how to properly clean stuff up now. I’m drawing lines for almost everything and using push/pull if I feel lucky.

Hope for some guidelines/directions to figure out what I’m missing. (Google is my friend)

It’s a good start for a new use. You should set it aside for a bit and go through the Fundamentals at

You need to be using groups and components and learn to use those properly before you get started with tags. You should get in the habit of correcting face orientation when you have exposed blue back faces and if your computer is acting sluggish as you navigate the model, avoid using textures and materials until near the end of the modeling process to give your graphics card a chance to keep up. (Make sure the Nvidia card is set to display SketchUp instead of the integrated GPU.

You should also get into the habit of cleaning house once in awhile. I purged unused stuff from your model and got rid of a bunch of stuff. I’m letting CleanUp run and do more looks like it’s got a little while to run. When it is finished I’ll return with the results.

Purge Unused:
Screenshot - 12_1_2020 , 6_12_48 PM

After CleanUp
Screenshot - 12_1_2020 , 6_24_56 PM

Your file is the third one. After all that purging and cleaning your file has been reduced by a little more than 62%. It’ll be more responsive then.
Screenshot - 12_1_2020 , 6_25_49 PM

myhouse purged cleaned.skp (13.9 MB)

1 Like

Thanks! I’ll have a look at those tutorials as well.

One more question.
When I disable View > Edge Styles > Profiles my framerate rizes from 10fps to 60fps.
Is that normal or part of my design? I guess most people will disable this option then…?
Is it usefull?

Ps. i7-6700k


That’s not unusual. Profiles add some extra work for the graphics card. SketchUp has to keep figuring out which edges are profile edges as you orbit the camera. With Profile turned off, it doesn’t need to do that.

A lot of people will disable it. I don’t but I do leave Profile set to 1. Without profiles enabled, some things can sort of disappear, especially with the Hidden Line face style.

Example from a model I am working on right now.

Profiles on and set to 1:

Profiles turned off:

For me, the reduced frame rate isn’t really noticeable and the profile edges are more important than the little bit of frame rate increase I might see by turning them off.

1 is already a lot better than 2. 30-50 instead of 10. Great :slight_smile:

1 Like

Profiles are how SketchUp marks what it thinks should be the visible outlines of things in the view. Sometimes these are real edges. Heavy profiles can help you find places where an edge does not cut a face.

But other times, as in what @DaveR showed, SketchUp’s shading creates the illusion of a smooth surface. Because everything in SketchUp is represented as flat polygons, there might not be any real edge at the visual boundary of a quasi-curved surface. Without the profile, it wouldn’t be clear where the object’s boundary is. In fact the object can seem to disappear!

SketchUp has to examine the model based on the current point of view to determine where profiles should be displayed. Then it has to pass that information across to the graphics card each time the view orbits. If profiles are wide, it has to create the fake geometry to pass across. This extra work slows SketchUp down, sometimes quite noticeably.

1 Like