Beach ball (performance) issue (SU2018 + MAC)



I’ve switched to SU18 (from SU16) and really suffer from performance degradation… I’m having this mac ‘beach ball’ so often that I don’t know what to do. I thought it was ‘autosave’ but no… It happens when I rotate camera view, select something, change tool, etc… Then my mac laggs for 10-20 seconds.

I use MBP 15" / 3.1GHz i7 / 16GB RAM / Radeon Pro 560 4Gb / HighSierra

Please help!


Does it happen with any file? If not, what size is the file causing the problem?

My Mac has a 2.7GHz Intel Core i5 with 8MB of memory and a graphics card with only 512MB capacity. So it won’t be your hardware.


Hi @simoncbevans!

Sorry for delay. Actually it happens with almost every file, and since I’ve been doing interior designs those files are usually between 500-700 Megs. You could say that files are too big to make SU work properly, but please note, that my previous configuration (SU16 + weaker Windows laptop) worked like a charm…

Could you advice anything?



I didn’t reply to your first post as I had no idea what was wrong. You now mention that you work with 500-700MB files, which would probably slow SketchUp down on most computers. I thought the 2018 version was a bit faster, not slower, so you shouldn’t be seeing worse performance on a newer version. It seems like you’ve changed both software and hardware at the same time, so it’s not so simple to compare the two.

Check your settings in System Preferences / Energy saver. Make sure it is the Radeon card that SketchUp is using and not the Intel integrated graphics, especially if you’re running off the battery.

Can you share an example file for us to test? Preferably a lot smaller than 500MB that runs slowly on your computer. Smaller than 100MB if you can, to save you uploading and us downloading huge files. Try and make the smallest file you can that runs slowly, to help isolate the problem. You can’t upload files bigger than 3MB here, so you’ll have to use something like Dropbox to share the file.



I can try but not sure if I have any small file. I’ll check it out and let you know about it.



This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.