Bad rectangle dimensions


#1

Hello,
I have new user with SketchUp. I use the sw for a week, and something went wrong today. I planned a lot of basic shapes, and with the rectangle tool I made sqaures via dimensions write in. It worked properly till the evening. At the evening I used the program, and if I gave a dimensions for a square, for egsample, 40, 40 (mm), the program will not do it. It makes random sizes squares, if I measure with measurement tool, it will not the size, that I input in the dimensions.
It looks like totally random sizes, but only one size, the other one is sometimes 40mm, sometimes 40.4 mm.
I have no idee how it is possible, but if I give 40 to a round, it will be perfect. It looks like the square function is damaged.
Any idee?


#2

It sounds like you aren’t entering the dimensions correctly. Exactly what are you typing in the Measurements box for the dimensions? Do you normally use a period or a comma for a decimal separator?


#3

If your locale uses a full-stop [kka a point = . ] as its decimal separator, then
40,40 with no space
should work.
If you are in a locale where the decimal point is a comma [,] then the separator between the two entered dimensions needs to be a semi-colon [;] NT a comma [,] - otherwise that comma could clash with any decimal separator…
So try also
40;40

Also don’t click on the Measurements input box [aka the VCB]… just type values, clicking the box with mess up.


#4

Thank you very much the problem was that I’ve tried the “,” and not the “;”. It works now properly.
Regards
AJ