Auth Token cannot be used

Yes now it did !

Based on advice from another topic thread on the same issue, I signed out of SketchUp using the “Help” tool in the software and then signed back in again using the “Help” tool in SketchUp. So far, smooth sailing.

2 Likes

I have seen this twice today.

Auth Token cannot be used. The User must sign in

I actually reinstalled Pro 2022 and still when I try to open another .skb while being in one already, I get this message. I really do not have time for these bugs. It is very frustrating. I have been using SketchUp for like 16 years and never have seen this problem until installing 2022.

Where is SketchUp on this?

1 Like

Reinstalling doesn’t change the AppData and usually takes longer than signin out and back in.
Some data might get corrupted when the servers have a fall out, like some days ago.
If one knows where to look for those files (webcache folder and login_session.dat) you better remove those instead of reinstalling.

I had already tried signing in and out multiple times and still would get the message even when it shows I am signed in. That was the first thing I tried. I mean every problem is not user error. It just seems SketchUp is not monitoring the forums much. And how is a normal user suppose to know about the appdata issue you mentioned. We are designers, contractors, builders, whatever, not computer geeks. The geeks are suppose to keep these things fixed so we can build things. Come on man.

And why does big brother have to know every time I open a different file on my pc? I have to be logged in to open files on my own desktop? Jesus.

2 Likes

For the prices we are paying, they should have their login process work better. We don’t work for them ~ they should be doing their own debugging.

2 Likes

Thanks for this - solutions in that forum topic worked for me. What a pisser though . .

Hope it doesn’t happen again. My colleagues in support had a very busy week.

This is happening again. Second kpbarbee, when using Sketchup I’ve had to become my own IT department. I’m already opening Sketchup files directly from my Mac’s file folders in response to another work-around which contracts the tag window so as to be unreadable. For all I know that’s causing the unauthorized token issue. All of this has to be fixed as soon as possible for those of us in voluntary servitude to the Sketchup app for the rest of our professional lives.

The Name column issue happens half of the time, and is unrelated to the auth token problem. That issue only showed up with 2021.1.2, if you are using 2020 you shouldn’t be seeing that problem. It’s fixed in the current 2022.0.1 version.

Someone else also reported the auth token issue today. It seems like it isn’t yet fixed. Try the signing out and in from the Help menu idea, or delete this file and reopen SketchUp:

~/Library/Application Support/SketchUp 2022/login_session.dat

You can get to that file by using the Go menu in Finder, and choose Go to Folder… then paste in the text I gave.

If you are using 2020, change the text to say 2020 instead of 2022.

Do you mean if I’m using 2022, to change the filename text to 2020?

If you are using 2022, the text I gave is correct. If you were using 2020 (which your profile says you are), then the path would be:

~/Library/Application Support/SketchUp 2020/login_session.dat

I will change my profile. I am using 22.0.315.

Thanks. The current version is 22.0.353, and it has some useful fixes in it (including the Name column issue). It won’t help with the auth token problem, but is worth having. Here’s the Mac disk image:

https://www.sketchup.com/sketchup/SketchUpPro-full-dmg

Thank you. I still have to close and reopen Sketchup every time to open a new file. Please announce when that has been fixed.

Same here and all they say is:

  1. Sign out of SketchUp

  2. Close SketchUp completely (If you are on a Mac, please be sure to go to your Dock and right click on SketchUp and LayOut and select either Quit or Force Quit)

  3. Reopen SketchUp

  4. Sign back in and see if this resolves the issue.

I did and still is NOT WORKING.

1 Like

Same issue here :persevere:

delete the auth. status file “login_session.dat” as already elaborated above…

attached Windows batch scripts for deleting the “login_session.dat” file of the latest SketchUp versions 2019-2022 by simply running/executing the according script.

If you don’t trust you can peek in the content of the batch file (text format) with every plain text editor.

DELete SketchUp Pro Authorization Status File.bat.zip (1.4 KB)

2 Likes