Arc and Curve Tool Keyboard Shortcut Registers in Status Bar

In Sketchup 2024, when I use ‘a’ or ‘c’ to activate the Arc and Curve tools respectively, the input (‘a’ or ‘c’) shows up in the Status Bar in the (Measurements) Sides field. So when I then want to change the number of sides, the field input is ‘a6’ rather than ‘6’. With the Arc tool, this doesn’t result in an error message, but it also doesn’t accept the input and change the Arc tool appropriately. With the Curve tool, the input reads as ‘c24’ and after hitting enter, the error message pops up telling me the input needs to be a number.
I am on a PC running Windows Pro 10.

You mean SketchUp 2023, correct?

It’s a known issue and it’s being worked on.

Please fix your forum profile. It is not consistent with what you wrote in your post. Also, you can’t possibly be running SketchUp Pro 2024, as it hasn’t been released yet. Giving correct information helps us help you!

I thought this sort of issue arose from the conversion of the Windows SketchUp GUI to the Qt library. Shouldn’t be happening on Mac, which hasn’t been converted yet.

1 Like

Yeah, it’s 2023. It was installed recently, so I’ve been calling it 2024 in my head.

Thanks.

I call it robert, but i suspect others may be confused by that. What can it matter tho.

1 Like

And I mentioned this was on a PC, not a Mac.

But youu put Mac in your forum profile. How about fixing your forum profile so it is accurate and makes sense?

That’s probably been there forever. I just came back after however many years simply because of the bugs in the latest version, and didn’t even remember that info is in the profile. I didn’t reiterate that it was a PC and not a Mac to be indignant, like your response reads like, nevertheless I have now updated my profile to show both operating systems I’m working on to accurately reflect my setup. Thanks for the rude reminder. With this kind of response, I’ll probably be back in another 5 years or so after I forget this encounter.

It took a long time to get those fixed. I tried in a recent build, and a, c, and z, now seem to let the value you type appear in the measurements box, and no sign of a, c, or z.

I can’t tell you when the next update will be coming out.

Came across this bug too where the keyboard shortcut (a, c, z, and v, which is my custom shortcut for FOV) would type itself into the measurements field whenever I type the shortcut. It’s not consistent, but I can easily replicate it. Depends what tool was active before, but always occurs when the selection tool was last active.

Realised I haven’t updated my Sketchup in a while, but not sure why it’s suddenly popping up because I wasn’t having this issue a few weeks ago and the last version I downloaded was SketchupStudio-2023-0-419-179 and installed in May 2023.

Anyway, downloaded the latest build (1-340-117) just now (https://www.sketchup.com/download/all) and ran the install file just in case. Then the option to repair or remove the installation popped up. A bit surprised because I thought newer versions would seamlessly install over the older ones (https://help.sketchup.com/en/installing-sketchup).

So I cancelled the setup process, opened Sketchup and checked the version I currently have, and it was v23.1.340, which seems to marry up with the latest build I downloaded, but had not installed yet. Um, ok! I figure Sketchup updated itself (nice!), but this brings me back to the keyboard shortcut in the measurements field bug. It now exists on the latest build of Sketchup 2023 I have installed.

So, I opened the setup file again and chose Repair. Bug still not fixed.

Manually uninstalled Sketchup, reinstalled from the downloaded 1-340-117 setup file. Bug still not fixed.

Might have to go back to an older build if this frustrates me too much. I have the 0-419-179 build from last year but would appreciate if anyone knows how to download any later 2023 builds but earlier than the latest one. Thanks in advance!

well off course.
the thread you’re answering to is from 15 days ago.

JosephO was using 23.1.340 too

the “recent build” Colin is mentioning is sketchup 24, in beta.

then it’ll be 22. pretty sure the first sightings of this bugs started rapidly with 23. and if not with the initial 23 release, well it was full of other bugs so…

You can instal several yearly version. So 22 and 23 is ok, but windows will see 23 and 23.1 as the same.

Thanks. Although, I am aware the last comment was only 2 weeks old. My post was based only on the available information I gleaned from the other comments, and I saw a potential discrepancy between colin’s “recent build” not having the bug against the latest build that I have access to that did. I didn’t know Joseph0 was using the 23.1.340 build and I didn’t know colin’s “recent build” was in reference to a beta build – unless I missed something, none of this information was mentioned in any of the post’s comments prior to mine.

Thanks. Will try different installation files I’ve saved and see how I go.

That, and the fact that Colin’s profile says that he’s an sketchup team member.

I don’t understand the point of your reply.

edit: You quoted my statement “unless I missed something”. However, neither your statement nor the statement you quoted (of colin’s) provide any corrective insight into what I could be missing. I am aware colin is a Sketchup team member, and I am aware that colin couldn’t tell us “when the next update will be coming out”. My last sentence in my post remains true - none of the information that I referred to in ateliernab’s comment was mentioned in any of the prior posts.